Mod Duo affecting internet connection when plugged in

Not sure if this will fit in the bug category here on the forum as this might not be the Mod Duo’s fault. But I thought i’d ask anyway.

Is anyone else experiencing having trouble using the internet when connected to the Mod Duo via USB. Occasionally websites fail to load (can be rather annoying when trying to browse the pedalboard website). It feels like the computer thinks the USB network connection between the computer and the Mod Duo is a valid internet connection and tries to load a website through that rather than the wifi.

I am on Ubuntu Gnome 16.04.1, 64-bit.


Did you already install version 1.2.0-RC1? If not, please manually install it and let us know if you still have the same issues.


Just tried installing 1.2.0-RC1 and no difference. Still seem to be getting server not found errors in Firefox occasionally (not always), but only when I have the Mod Duo connected. The moment I unplug it the internet connection works fine.

Could you give it a try with a different browser? Chrome / Chromium seems to work for most people.

To verify: you are getting DNS-server not found errors, correct?


Chromium-browser Version 53.0.2785.143 has the same effect. (in the following example error code I tried browsing, but other websites failed in the same way)

This site can’t be reached’s server DNS address could not be found.
Checking the proxy, firewall, and DNS configuration

This starts happening pretty much instantly after I plug in the Mod Duo. (and everything starts working fine the moment I unplug the Mod)

@JohannesG I think your usb interface is set as default adapter so your internet routing is not happening through eth0 as the primary option.

Take a look at this article, it explains the problem a bit and might help you fixing it.

The article explains how to set usb as the default interface, what you want to do instead is to set your ethernet adapter as the default.

That might help, but shouldn’t be needed I think.
Automatic setup is always preferred when possible :wink:

Please try this build
It’s going to be released officially tomorrow.
I was able to reproduce the issue and this new build fixes it for me.
Would be nice to have a confirmation that it’s fixed for you as well.

I had the same problem on my Debian Jessie : when connecting the Mod, I could not reach external websites anymore.

What happens is that NetworkManager overwrites /etc/resolv.conf with


Basically, DNS queries are now routed to the Mod (!) which causes them to fail.

The solution, is to run


from the command line as root, then to click on the interface
corresponding to the mod-duo, to select the ipv4 tab and to set the
correct DNS address ( on my local network).

Also set Automatic addresses (DHCP) only instead of Automatic addresses (DHCP)

Then click apply and the problem should go away.

I hope this helps

Actually I was a bit optimistic here :
The Mod seems to be changing its presented MAC address after each reboot. That confuses NetworkManager which thinks it is a new connection and therefore doesn’t apply rule for setting the DNS.

I ended up listing usb0 in /etc/network/interfaces so that NetworkManager leaves it alone, and adding
supersede domain-name-servers

to dhclient.conf so that DHCP does not change /etc/resolv.conf when plugging in the Mod.

Seems to work now, even after computer or mod successive reboots

Did you try 1.2.0-RC2 yet?
It’s supposed to fix precisely this, so we don’t need ugly workarounds.

1.2.0-RC2 seems to have fixed the issue for me. Hard to be 100% sure about it as it only sporadically affected the internet connection. But I’ve had it connected for about 5 minutes after upgrading it, and have had no problem browsing the web during that timeframe.

Thank you very much!

Just out of curiousity: how did you fix it?

1 Like

DIsabled the DNS server part of dnsmasq that runs inside the MOD, and a few other small tweaks for it.
Also made sure the Duo does not attempt to go online, so no network timeouts happen.
(the Duo itself never connects to the internet, the browser does which is running on a separate system)

Nice! This sounds indeed like solving the issue at its root.