MIDI Step Sequencer8x8 - MOD Devices

Robin Gareus

A simple step sequencer. It allows to trigger MIDI note events placed on a time/note grid. The Step-duration is configurable to musical time and can optionally be modulated for a swing-time effect. This plugin version contains 8 notes and 8 steps.

This is a companion discussion topic for the original entry at https://pedalboards.moddevices.com/plugins/aHR0cDovL2dhcmV1cy5vcmcvb3NzL2x2Mi9zdGVwc2VxI3M4bjg=?__hstc=181257784.c1fd10cdc5d7b47d9844ea4282cb6c38.1505845345508.1505845345508.1505859166504.2&__hssc=181257784.3.1505859166504&__hsfp=194074958
1 Like

Hello, I am using two “step sequencer x8” together. They are syncronized internal but when I run them they stop for a while and then continue and so on. Anyone know what’s going on? I thank you in advance!

What do you mean with “stop for a while and then continue and so on” ?
Maybe show a screen-cast of this behaviour?

I use multiple instances of these all the time and do not get random stop/continue.


Yes is a random stop/continue. you know what it can be? in free running mode they work fine but are not synchronized.

Can you show/share your patch perhaps? I haven’t seen this at all.
In my patches the sequencers stay synchronized with the main transport.


As @dreamer suggested maybe you are just not synchronising it with the main transport. Let us know if you manage to get it working as supposed.

1 Like

thanks for answering! Here I send you a photo of the patch … excuse my ignorance! How do I sync with main transport?

1 Like

You need to press the sync button in between the BPM and PANIC.

The BPM should say Host Sync and then the sequencers will run together with the main transport controls.

1 Like

Yes. both are in sync but it’s always the same. in the photo does not appear in sync but they are

They are not, they very clearly say 118 which means you set the BPM manually.
Press the sync button next to it to enable Host Sync.

Do you see the difference between these two?


Yes. that’s what I did but it continues

Well that is super weird. For me all the sequencers completely wait until host transport is running and are idle otherwise.
Not something I can reproduce at all.

Maybe check if you have any plugin updates available?

1 Like

@dreamer, @jon Hi! well, i redid the patch with another computer and it works. I think the internal clock of the computer I used does not work well with Mod Duo X. In any case, now it works well! Thanks for your help!!