Max Gen~ Trial only?

Sorry, I don’t want to overload topics, but I’m stuck with this problem:

  • I built a plugin from scratch using Max Gen~, everything went fine from design to transfer to the Dwarf, but it’s labeled “TRIAL”, cutting out audio at regular intervals. How can I remove this trial only mode?

(Info: I have Max/msp permanent licence)

1 Like

it seems like you have built your plugin as a commercial paid plugin.

1 Like

Thank you GianFranco (by the way thank you for all the work you do, you and the Mod staff…)

It was not my intention to make it a commercial plugin.
I haven’t seen a commercial or non-commercial option during the process with the Max Mod-Duo Launch package, did I do something wrong ?



By any means, tell us more about your plugin, here in the forum when you are releasing it!

1 Like

Of course…


Still stuck with this case…

So I tried with the empty example of the MOD-DUO Launch, but the problem remains the same: only TRIAL :

Another strange thing is the appearance of two knobs in the name of the two buffers used in my plugin while no parameters are assigned to these buffers in my GEN patch…??

So I tried to compile the plugin without the MOD Duo-package in Max, following the Additional features (advanced) of your Max Gen~ wiki with the max-gen-deploy folder method, but no success to get the tar.gz file, here are the last lines in my Mac Terminal after sending the command $ ./ :

File “/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/”, line 579, in init
File “/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/”, line 808, in do_handshake
IOError: [Errno socket error] [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)

Any help welcome. Best

The extra parameters are a side effect from how max gen works, you can just ignore those parameters.
If they really bother you, edit the main plugin ttl file and set those as OutputPort instead of InputPort.

On the python error on macOS terminal, that is an issue on macOS not having updated certificates.
Because python 2.7 is really, really old.
If you install python3 through homebrew or macports, and tweak the script to use it, it will fix this specific issue.

That said, that script needs update in order to support duox and dwarf.
I thought @acunha already did that, but it was not the case. I have it as a task for myself to do.

And finally, regarding the “trial” plugin, somehow the plugin is being identified to be built as commercial. I don’t know why yet, will investigate.


Thanks for the answer Filipe,

Of course the extra parameters are not an issue. I’ll try the python3 installation, though I’m just musician with average skill in Max/msp but not a programmer…
Anyway the biggest problem is really this Trial mode, so I’ll wait the results of your investigations.

Muito Obrigado

1 Like

Hi Filipe @falkTX , any news about the script update?

“On the python error on macOS terminal, that is an issue on macOS not having updated certificates.
If you install python3 …”

I installed python 3 but there is another problem:

pipoz-6:max-gen-deploy jphz$ ./
Please type your plugin name, then press enter to confirm
Traceback (most recent call last):

  • File “/Volumes/SSD FICHIERS /FFFFICHIERS SSD leop/MAX ZW/Nouvel_essai_pour_Dwarf/max-gen-deploy/resources/”, line 11, in *
  • from urllib import urlopen*
    ImportError: cannot import name ‘urlopen’ from ‘urllib’ (/Users/jphz/.pyenv/versions/3.9.12/lib/python3.9/urllib/

Have a nice day

Sounds like a bad import, made for python2 but never updated to python3.
The correct line should be:

from urllib.request import urlopen

Will check on this soon, but only have time next week


OK, thanks .

1 Like

Any news?

And as it seems that the Mod Duo package for Max doesn’t work for the Dwarf, when will you release a Mod Dwarf package for Max ?

This was the answer from Gianfranco when I asked him on the Cycling74 forum, if the integration of gen patches will be possible on the Dwarf :slight_smile:

" The answer is yes. The platform is the same and, once it is out, we will work towards also supporting regarding the MaxMSP integration." february 2021.

Best regards

1 Like

The MAX Duo package will work for the Dwarf too, that part is already in place as far as I know. (but the demo part is weird and for sure not expected, a bug/error on our part).

I am looking into TTAP now, doing the final integration steps, so will try to sort out this builder situation too today.


Hi Filipe,

Whats new with the demo mode problem ?

By the way, about my plugin (MIRROR), here is how it works:

  • A 20 seconds buffer record permanently the audio inputs.

  • Pressing footswitch 1 (momentary on) plays backward the last chord/melody/percussion played, releasing footswitch 1 stops the play.

  • Pressing footswitch 2 (momentary on) plays backward the last chord/melody played, releasing footswitch 2 loop the audio just played backward. Pressing footswitch 1 stops the loop.

  • Playback speed configurable 0,5x - 1x - 2x

  • Vol ramp time adjustable to avoid clicks

I’d be happy to share this plugin with the community, but it still requires some live testing, which is just impossible with the audio cut at regular intervals…



I think I found the problem and a fix for it, triggered an update to the cloud builder just now, but will take a few hours before it comes online again. So around noon tomorrow (2022-04-20) hopefully the demo/trial mode situation is fixed.

I also updated the Max gen~ - MOD Wiki page so the tar for manual procedure is now at v6.
Changes are to support both python2 and python3 (tested with the latest python3.10) and also support for multi-device builds. The same ./ script will give you duo, duox and dwarf builds all at once. The ./ then needs an argument to specify which build to deploy, but will try to find it automatically if possible (requires jq command-line tool to be available).

Will let you know tomorrow if the cloud side build went ok.


Demo/Trial mode should be fixed now, sorry for the inconvenience.

Try it out when you can and let us know if it works correctly now.


YES, wonderful, I just tried, the demo issue is fixed. It worked perfect with the Mod Duo Launch.
I did try also the manual procedure and it’s ok too, it gave me back the lv2-dwarf.tar.gz file.
Bravo !
I’ll look into editing later.

(just for information, the max-gen-deploy_v6.tar.gz uncompressed give a max-gen-deploy 5 file)

So again, thanks a lot for your help Filipe.




Here it is :slight_smile: MIRRORZ playing backward