Max gen~ build fails

@dreamer @DaveM

It’s back up. Just tested building the sample project and it works.
It’s worth noting that you have to use the https url as discussed earlier in this thread. I’m going to update that bundle to have that corrected soon.

1 Like

I uploaded a new bundle and fixed the wiki page.
Thanks for pointing this out guys, let me know if there’s anything else you need help with.


I can confirm it works now. Thanks!

1 Like

I no longer have a MAX/MSP license so I cannot test/use this feature.

Hi ,

I just tried to compile a fairly simple GEN patch (just a very long stereo-delay), following the WIKI pages, and got the following errors:

Omni@OmnisM1 max-gen-deploy % ./
Please type your plugin name, then press enter to confirm
Submitting process…
Got release process 61379dad96c4f7c7718404d5.
Uploading buildroot package…Done
Checking md5 52a46a23820df01a55b8ee26d8e77aa7 …Done
Waiting build (this can take a few minutes)…
Error: Process 61379dad96c4f7c7718404d5 failed, contact MOD Team for more details

Here is the patch and the inside of the gen object:


Hi @Omnichordman . Thanks for your report.

This is a different issue. Let us investigate and we’ll get back to you.


Can you try renaming the exported files as gen_exported.cpp and gen_exported.h and running the script again?

1 Like

Hi falk,

I did that.

1 Like

…and? same result?

1 Like

It did not even start to compile with other names.
Funny thing is, I just found a delcore1 in the plugin list, which is my name for the gen object, before renaming.

Does not work though…

Yeah I found out why now.
One step of the cloud builder is not being run, which renames the includes in order to build.

This is made for GNU sed, so not sure if it runs on macOS as-is. But you can try:

sed -r 's/(namespace )(.*)\{/\1gen_exported \{/g' -i gen_exported.*
sed -r 's/(#include )(.*)/\1"gen_exported.h"/g' -i gen_exported.*

(which are the steps the cloud should be running but is not)

we basically want to edit the files to convert custom names to well-known name for compilation, that name being gen_exported.
after modifying the files you should be able to get this to work.

we will fix the MOD cloud side too, but that can take a bit.

Thanks Falk,
I will try that later. Can I use a terminal program for that?

I am not a coder, just Max/MSP experienced, tapping into GEN now…

1 Like

You have to use the terminal :wink:

But okay, understable if you dont want to try, since I dont even know if it will work as-is.

I just pushed the fix to our cloud code, will need to rebuild the images and redeploy.
Now passing the ball to @acunha again :sweat_smile:

You bet I will try…. :wink:

1 Like

Cloud pipeline has been fixed (or at least applied the tentative fix from falk :stuck_out_tongue: ).
@Omnichordman please try again.

1 Like

It worked, I got a LoongDelay.lv2-duo.tar.gz file back. I had to rename the files to gen_exported though, before it worked. Now I am stuck somewhere else, see here:

joker@JokersM1 MyLongDelay % ./
Missing gen_exported.cpp/h files, please copy them to this folder

joker@JokersM1 MyLongDelay % ./
Please type your plugin name, then press enter to confirm
Submitting process...
Got release process 6138f54096c4f7c7718404e0.
Uploading buildroot package...Done
Checking md5 85ea9be40a04f46b613a44f23aef27f5 ...Done
Waiting build (this can take a few minutes)........................................
Error: Process 6138f54096c4f7c7718404e0 timed out, contact MOD Team for mode details

joker@JokersM1 MyLongDelay % ./
Please type your plugin name, then press enter to confirm
Submitting process...
Got release process 6138f7ba96c4f7c7718404e2.
Uploading buildroot package...Done
Checking md5 7fd3eb00d211c678741e55c88474bfe1 ...Done
Waiting build (this can take a few minutes)..............
Finished downloading LoongDelay.lv2-duo.tar.gz

joker@JokersM1 MyLongDelay % ./
{"removed": [], "ok": true, "installed": ["urn:maxgen:LoongDelay"]}
joker@JokersM1 MyLongDelay % 
joker@JokersM1 MyLongDelay % sord_validate $(find /path/to/LoongDelay.lv2-duo.tar.gz -name '*.ttl') $(find /path/to/bundle.lv2 -name '*.ttl')
find: /path/to/LoongDelay.lv2-duo.tar.gz: No such file or directory
find: /path/to/bundle.lv2: No such file or directory
zsh: command not found: sord_validate
joker@JokersM1 MyLongDelay % 

Excuse my ignorance, it´s day three in lv2/Dwarf land…

I am a step futther now I guess, after reading your post here:

I got a loongdelay.lv2-dwarf.tar.gz file back without errors. I will explore how to get it a skin.

If you get into issues not being able to run mod-sdk (which to be honest needs some maintenance work on our side) we have been internally using a special build which provides a few extra developer tools. Basically v1.10 + carla + mod-sdk + valgrind.
Will post a build here once it is finished.

1 Like

ok went a step ahead and added a little bit of documentation as well.
See Developer Images - MOD Wiki


@falkTX thanks for the headstart! I will look into it asap. Does it make sense to work from a Linux Ubuntu enviroment, insted of Mac OS? Seems like all the tools are ready and availiable there.
I could use my Raspi 3 for that.