Making a plugin, need help with MOD-ui

Hello. I attempt to port my existing plugin to mod.
I’ve made a setup with jack and mod-ui, because I don’t own a device.

As I instantiate the plugin in mod, the sound processing works but I have trouble with the manipulation of parameters.
I click on the gear icon to visit the parameters, I changed a real-valued parameter rotating a knob, and I notice a strange behavior: the parameter is sent to the effect only at integer steps of the interval.

As example I have “Output gain” valued 0 to 3, that is able to send just (0 1 2 3) discrete values. The same plugin had no such problem in either Carla or jalv’s generic UI.

The manifest used

I took mod-host and mod-ui from git master. Any idea?

I know at one time MOD-SDK would complain that I had put e.g. 1.0 and 10.0 as the min and max of an integer control. Perhaps it is also picky that on a value that should be floating point, omitting a .0 on the bounds makes it assume its an integer. Thats a bug on their part if it is that way, but it might be something to try.

@ssj71 this changes nothing. I found a more interesting thing: the other plugins are also affected. I ran AmpVTS from caps, it was an identical problem; any of 0…1 controls have acted like booleans.
I found the knobs of the front and the settings panel to be affected the same.

I ran these versions of software.
mod-host-git 0.10.6.r272.387630e-1
mod-ui-git 0.99.8.r2220.03ede9bb-1