Looking for advice on levels within a Dwarf to PC/Ableton setup

Hey fellow Dwarfers (Dwarves?)

So I’m still very new to all things MOD/Dwarf and am learning lots as I go. I’m having an issue with my slightly extended DAW setup and I was wondering if anybody here has experienced something similar; and if so, whether I might ask for some recommendations on how to resolve this.

First of all, let me get this disclaimer/caveat out of the way: I don’t think there is any problem or issue with the Dwarf itself whatsoever; I’m surmising that my issue has something to do with setting levels between different interfaces. It seems to me that ‘the devil is in the details’ within any degree of sophisticated signal chain, so I’m sure there are just some settings I need to deal with.

So let me explain my conundrum:

  1. When running my virtual rig most simply (electric bass, via Darkglass Clean Bass Preamp and Ernie Ball EVP volume pedal, into Input 1 of the Dwarf, headphones into Dwarf headphone jack, and USB connected to PC to enable access to local pedalboard GUI), everything is hunky-dory; runs perfectly, sounds great. No ground loop issues.

  2. When I run a cable from the Output jack of the Dwarf into the Input jack of my Focusrite Scarlett 2i2 (thence into my PC into Ableton Live 10), I suddenly have the potential to hear all sorts of extreme noise and/or unwanted distortion. Now, from twiddling some knobs, etc. I’ve noticed a few things already. Firstly, pushing on the INST (instrument input) button on the front panel of the Scarlett seems to boost the signal way too much, whereas deselecting that resolves some (but not all) of that. I don’t have this problem at all when simply plugging my bass direct to the Focusrite. Secondly, I need to dial back the input gain on the Focusrite to about half the level I have it at when playing into the Focusrite without the Dwarf in the chain. Thirdly, any effects rack in Ableton has to be turned off or deleted, especially a compressor or limiter or amp/cabsim (OK, no problem there; with my new Dwarf, I shouldn’t need Ableton’s FX on the input channel anyway). Fourthly, I need to play my bass fairly gently; any aggressive fingerpicking or chords can trigger some clip, even with levels down low. I should mention that I’ve also checked to make sure that none of the obvious factors, such as channel levels within Ableton, could be causing these issues; they’re all set properly and Ableton shows no signs of input clipping after doing all of the above. I’ve also gone into Settings on the Dwarf and dropped the Output levels to 50% or less.

So I guess what I’m saying is, that compared to playing my bass through my simple Scarlett-PC-Ableton setup without the Dwarf, I have no issues with noise or unwanted distortion. Conversely, the Dwarf runs perfectly when not connected to my Focusrite box. But when introducing the Focusrite into the Dwarf signal chain, I have to be EXTREMELY careful with input levels, as the potential to overload the signal chain suddenly seems to skyrocket.

I have no doubt that all of this is a reflection of my technically unsopshiticated newbie level of experience and knowledge and somebody out there might be able to advise me about something to do with impedance or something. If you have any advice as to how I might optimize my setup even further to eliminate this noise and distortion I’m describing, that would be much appreciated. Maybe there’s a different alternative to the Focusrite for getting my Dwarf output into Ableton on my PC (???). Have any of you using a similar setup experienced any of these issues?

All that said, I remain totally impressed and inspired what this amazing box and software are capable of doing - loving the Dwarf!

Frank in Vancouver


Hey Frank,

This sounds like a struggle bus I’ve been on before.

Can I ask what you have your input gain on the dwarf set at?

Also, have you attempted to use a Bluetooth dongle for the GUI? I won’t use the USB on the dwarf because I struggle with ground noise. The Bluetooth dongle solved most of the noise issues I have.

I send tracks from my mixer out into the dwarf. The settings I generally use are (0-14%) input gain, 100% output gain, and then use my mixer to address the gain imbalances if they arise. I don’t use a daw, so I have to handle most stuff live the best I can.

If I can’t accomplish that way, at the beginning and end of my effects chain, I’ll throw in either the stereo/mono-gain plug-in to balance levels internally.

I’m not sure of that work around may be useful in your situation, but it might be something to try out.

Also, idk what your pedalboard looks like in your patch, but keep an eye on the CPU usage. I have a hard time maxing out my CPU on my dwarf since I’m real simple with mine right now as I’m exploring its features; but I’ve used some boards that will hit the cpu limit and crack the audio.

Hopefully someone who is closer to your specific use case can chime in if they have experienced an issue like yours.


Hey Elk_wrath

Thanks for sharing your thoughts on this topic. Great to cross paths with you again!

Re: Dwarf input gain. When initially using the Dwarf in standalone mode, I had this set at about 80%. But on hitting that noise wall the first time I tried to complete the connection into Ableton, I immediately dropped this right down - to as low as 15-20%. That helped, but didn’t resolve the issue entirely. Right now, I have it at about 50% and my thinking is that this should be moderate enough that I shouldn’t expect to run into difficulties. If the system can’t accept at least 50% gain without noise/distortion, then I’m thinking I must have some other problem. Again, I’m presuming this is not the Dwarf’s fault but rather something else in my signal chain.

Great suggestion re: the dongle - thanks. I saw it in the box but hadn’t used it yet simply because I didn’t think I needed to. I’ll give that a try by tomorrow and see if that helps. Also re: the use of a gain plugin at the start of the signal chain - will give that a try as well. Will report back later.

Re: CPU usage. Another good suggestion, but I think that I’m rarely getting above about (hazarding a rough guess here) 50% or so, as my usage has been fairly simple/minimal. So far, I’ve been mostly downloading and using a few of the member shared pedalboards, and haven’t built out any of my own yet until I have a better feel for how I might want to line blocks up specifically to enhance the 6-string bass I’m working with. (But damn! Those MIDI step sequencers driving synths and virutal percussion instruments look real damn fun too :smile:)

Anyways, thanks again, Elk_wrath - I’m definitely going to try the suggestions you offered.



Hey Frank,

Glad to chat with you again.

In terms of the input, 50% is so high for my machines. Most of my stuff is line level rather than instrument level. So I have to be real cautious about my gain input on the dwarf.

I’m really hoping that adding the gain plugins help out a bit, tbh I’m kinda stumped about your issue, but that’s coming from a place of unfamiliarity with your particular set up.

In terms of the dongle, I don’t believe mine came with one and it was a cheap buy off of Amazon, definitely double check and see if there actually is one in there.

Worst case, this is the dongle I snagged and have had zero issues: Amazon.com

Honestly, based on your cpu usage, there should be no artifacts in your audio stemming from it.

From my very limited experience, I’m guessing this is a gain staging issue. I’d try to lower your input gain and fiddle with the gain plugins to see if maybe it helps, if that doesn’t help rectify your issues, I’m at a loss based on the knowledge I have.

Hopefully something happens l’ve recommended allows you troubleshoot and cover your bases if you end up needing a help desk ticket.

Best of luck, Frank!

1 Like

Hey Elk_wrath - thanks for that as well.

I’m starting to think that you really found the crux of this whole thing by suggesting it’s all about gain stages. I’ve never really had to deal with this before so it’s new to me. But maybe the key is that - reducing the output levels down real super low to avoid clipping. And then maybe adding a utilitity at the absolute endpoint of the signal chain (i.e. Ableton master track) to goose up the volume, if needed. Gonna focus more on that, plus the other suggestions you provided.

Thanks again!

p.s. - The dongle I found actually came in the Dwarf box when I received shipment last week. Sounds like same one as you got (?).

1 Like

Hey Frank,

I’m really hoping that is gonna be the trick to success, out of all the gear I’ve put hands on, this one needs the most attention to the gain staging. I’ll be honest and tell you that I actually can’t explain what “gain staging” is.

I have to just tune everything by ear, which actually takes a considerable amount of time due to my lack of specialized knowledge in this regard. You will probably have a much easier time than I did.

Also, I just checked my box for a dongle, and I did not have one, so if your dwarf came with one, then hell yeah! Save that money!

I’m interested to see if any of my suggestions have helped you out, so when you get the time to address it, let me know what the results were if you don’t mind!

Your successes are my future ones, and your failures are something I’m willing to spend time on trying to troubleshoot if I can!

1 Like

So here’s the winning formula I’m gonna try:

Lower output levels (from Dwarf) plus lower input levels (from Focusrite) + dongle = Success! :smile:

I won’t get at the little beast again until tomorrow morning, but I’ll definitely report back my results.

Thanks again mate!


Can’t wait to see if this helps you out!

Let me know if it doesn’t so I can experiment a bit on my end, but I think the gain staging thing is gonna be your bread and butter for this issue.

I’ll eat the crow if it doesn’t, and I’ll take it as a learning lesson. However, post your results of your experiments with my suggestions.

May Tyr’s good hand guide you, and may the wind fill your sails in this venture.

Best of luck and wishes,

1 Like

Thanks man - me too! I am not familiar with Tyr, but I’ll take help from wherever/whoemever I can get it, LOL . Will let you know how this works out. Cheers


Hi Frank,
I’m glad to finally get some more “techy” feedback/questions from your side :slight_smile: I guess it is a good sine :wink:

Are we talking about input or output gain? If it is the input I would say that it is probably way too much for the setup you described. Try something around 10% as a starting point.

I guess that here you are confusing with the USB stick that we ship with the devices. That is a storage USB and not a Bluetooth dongle.

I must say that I’m really happy to see the interaction between you both (@Elk_wrath and @Frank_Paul). You are so fresh in “the family” but with such cool enthusiasm and now you are also proving to be real community members and helping each other. It’s really nice to observe this :slight_smile:


Hey Jon - thanks for your note. To your question to me re: gain. Yes, I was referring to output gain. I’m super thankful to receive your advice about bringing that down closer to 10%. I have a feeling that adjustment alone will probably resolve most if not all of the issue I was experiencing. I’m glad that my naive newbie blunders are empathized with by more experienced users. :smile:

Soeaking of which: doh! USB stick not bluetooth dongle. Again I plead newbie ignorance. Thanks for straigthening me out. On that topic, though, would you recommend using a generic Bluetooth dongle, or should that theoretically make no difference to signal quality as compared to using the supplied USB cable?

Thanks again Jon

1 Like

Actually most bluetooth dongles wont work, since they need custom firmware and we do not ship with that at the moment.
Likely it is about time to do a table of known supported models on the wiki or something. @jon you are the wiki master, mind setting up something initially? I have 2 bluetooth dongles I can try.


Hey Frank,

That amazon link I posted is to the exact Bluetooth dongle I use and have zero issues so far!


This has worked without any issues for accessing the GUI. In my experience, the Bluetooth option is a bit slower than the cable, but it also eliminated the majority of the noise I was originally experiencing.


Awesome - thanks mate! Does the dongle offer any advantages over the USB cable?

1 Like

It really depends on your USB needs. Since the dongle is USB-A and there is only one port.

If you need the USB-A port for something specific, I just tested and verified that a USB hub plugged into the dwarf can still utilize the Bluetooth capabilities direct from the hub. So you should be able to expand that single port into multiple ones with a hub.

Since I don’t need the USB I/O on the dwarf, I just plug the dongle directly in.

Using Bluetooth killed most of the ground noise I was getting from the USB cable while accessing the GUI. So I would definitely recommend trying the Bluetooth route and see if that helps clean up some of the noise issues.

Also, would you mind sharing your pedal board?

I’d like to dig into it and see if I experience any of the issues you are experiencing, and if I experience them, it’ll give me a chance to experiment a bit to see if I can find anything to help mitigate your issue.

I am still thinking your input gain on your device might be contributing to this mess.

Highly recommend dropping the input gain down to 0-10% the only time I’ve ever been above 0% is when I plugged a microphone directly into the device for some vocal experiments.

Also, I guess I should ask what sort of cables are you using to connect from the dwarf to the interface?

I use balanced cables personally and they have been really effective with the mod dwarf.



Sorry if I’m jumping late on this thread. You’ve had the excellent help of @Elk_wrath, master “Dwarfer” and author of the Unofficial But Very Likely Official Dwarf Anthem. And I see you’ve figured out the most pressing issue, but in any case here’s what I’d suggest.

You have three issues here:

a. Output @ 75 to100% will be waaaaay to hot for any audio interface.

b. Using the INST switch in your Focusrite is a no-no. It increases sensibility to a range between 13-60dB, expecting a guitar/bass pickup level – which is in the -30dB range. Bear in mind that the Dwarf has balanced outputs, so if you have an input that is not line level, that’s the one you should use.

c. Your Focusrite interface internal processing might be adding to your overall gain. Whenever you are in a situation that lowering the gain a lot still produces a too hot signal for the computer, that means your headroom is minimal.

Regarding a possible ground loop, unless you are hearing a constant, low-frequency hum, you do not have a ground loop issue. Using a dongle as per Elk-wrath’s desciption surely cuts one possible loop path, but only if you’re having it. Best way to try is to set it all up with USB connected then, while listening to it, disconnect USB. If noise doesn’t change, then this is not an issue within your setup (considering Duo + computer, you’d need to cut the loop path between Duo + interface as well).

Your input gain has to be what’s appropriate for the Dwarf. If your instrument is coming in too low, that will force you to boost the output and that also raises the noise floor. So set up the gain while using the headphones and leave it at that. Work only with your signal processing within the dwarf – that is, what gain plugins you have before the output cable in the GUI – and then adequate your output.

Therefore, by

you will get a signal that is both clean INSIDE the Dwarf – properly adjusted for its internal processing – and that enters your interface at a proper level. How low you need to go is a bit of trial and error, but I suspect even 50% might be too much, if you’re using an unbalanced/line level input. Golden rule is: if you’re applying too much or too little gain in your interface, you have a problem.

The next step is to adjust the internal processing within your Focusrite. I don’t own one so I can’t tell exactly how, but most interfaces have a mixing software that will also adjust its own sensitivity and output. It is the case with all the ones I’ve owned (MOTU, TC Electronics, M-Audio and RME), and I see Focusrite has a software called Control, and other than adjusting levels for monitoring it may also provide you with a way to lower your output-to-software level. That is the case with my current RME.

Finally, enter Ableton. Unlike Logic and Pro Tools, it is more prone to have sensitivity issues. So you have to come in very clean and avoid any situation in which a dry signal (that is, you’re connected but you’re not really producing any sound from your instrument) keeps peaking at more than -50dB in your meter. With Live that happens very frequently.

Well, I have a Duo X, so maybe I’m a Duexxer?

Hope this helps.


Hey Elk. Thanks for your latest - I’m learning lots from you.

I’m not using my own pedalboard. I’m just using downloaded ones from the member site. For example Bill Vencil’s “Chords of Orion” (COO) demo. I wanted to study a few signal paths that others have put together before starting to build my own. I think you said you were not working with a DAW so unless you have an interface device of some kind I think you might find it hard to replicate my setup to test it. Just a thought.

So latest update: And let me summarize my note below by saying simply - Yes, adjusting the gain stages has really done a lot to decrease the noise I was hearing when connecting my Dwarf to my Focusrite audio interface, but that didn’t eliminate the problem; there is still some subtle but noticeable noise.

  1. Adjusted output gain down to zero, cranked input gain and headphone volume both to 100. When monitoring (with headphones) only the Dwarf in this fashion, it sounded superb. Again, no problems.

  2. Leaving everything on the Dwarf as is per above, when connecting the output of the Dwarf to the input of the Focusrite and changing headphone jack from Dwarf to Focusrite, I still heard noise, albeit at greatly reduced volume. I can’t totally describe it; it’s just audio dirt. Like a very subtle type of white noise with some tiny little squelches and stuff. I recorded myself into Ableton and when listening to the playback, the noise was there. So it’s not just the headphones; the audio signal Ableton is getting via my audio interface is noisy.

  3. All of which to say is that when using the Dwarf by itself (without out connection to audio interface) it’s great. When using some pedals plugged straight into the interface (without the Dwarf) it’s also great. It’s when I connect the two that the noise creeps in. Which is, like, totally weird.

I saw your suggestions about using a bluetooth dongle and balanced cords. I haven’t tried those fixes yet, but will - and will report back. But in the meantime, I’m still stumped why this is happening at all. I’m just used to the old fashioned world of plug and play stomp boxes and have never had this sort of issue plugging them into an amp or even an interface.

Anyways, at least I feel I’m on the right track and thanks to your advice, I’ve reasolved about 95% of the noise problem. Now I just have to figure out how to tackle the remaining 5%.



Hey QuestionMarc - Thanks so much for sharing your expertise here; this is great. Clearly I have a fair amount to learn about setting levels between different types of hardware in the chain. Not like the good old days (by which I mean being a teenager in the '70s; OK dating myself a bit) when there was no such thing as a DAW and all you had to do was line up a few stomp boxes and away you go, LOL. Today’s bedroom studio systems are clearly more complex, and sometimes finnicky apparently.

Anyways, I think I have the input/output issues in the Dwarf more or less resolved now. Thanks to you and Elk for setting me straight there. I think what I need to do next is look into your suggestion about internal processing within the Focusrite. Hopefully that will enable getting rid of the last amount of the noise I’m still hearing.

Thanks again for your help!



I actually learned a lot from this post and am actually going to make some adjustments to my set up with the info you just shared.

I appreciate your expertise on this!


Hey Frank,

So I do technically use a DAW for recording, just not for arrangement or processing. I use AUM on an iPad but I’m really simple with it.

I actually do have some noise coming from my dwarf still, if you listen really closely to the beginning of the MOD Dwarf video, you can hear it.

Does that noise sound similar to what you are experiencing?

I am actually going to use Marc’s suggestions in this thread and reconfigure my set up to see if it cleans up the minor noise I am still experiencing.

If the noise that you are describing is what I think it is, I experienced it only when the USB-B cable was connected to the dwarf. Sounds like RF interference coming from the machine it’s connected to.

I’ve had to completely forgo all USB in my set up due to terrible noise issues for audio, and have had to be pretty selective on my power supplies. I am missing some critical gear like a power conditioner and a DI box, so I’m wondering if maybe that might be contributing to the noise issue in my case.

I am glad to hear that some of the recommendations have been helpful in this situation.

I highly recommend trying out Marc’s solution, and I’m hoping he solved that last 5% of my problem as well as yours.

EDIT: so I messed with my input gain on my audio interface based on @QuestionMarc’s recommendation, and the noise is gone. I had fudged up a setting with my interface but now have zero noise.

On a side note: as I was getting all my gear fired up, my polyend tracker decided to brick itself, as well as wipe out all of my projects, samples, recordings, and everything else. It’s a sad day, and now my main sequencer is dead in the water, so I probably won’t be recording anything for a while lol