Linux drivers

Hi everyone,

I just received my Duo but the web interface at is not reachable.

The mod is powered ON and the USB cable is connected too.
I’m running Linux Opensuse Leap 42.1 on my laptop, I didn’t see any article about OS compatibility so I guess I should run without any problem.

For the linux users in the forum (if any), is there any driver which is needed for linux ?
Did you manage to get it work and on what distribution?

Thanks in advance

There is no driver needed in Linux, but you might have to manually connect to the network if the OS does not do that for you.
Usually this works:
sudo ifconfig usb0
I’d bet you just need to go to network devices and connect to the ‘Duo Ethernet’ though.

Tanks, I’ll try this and give you my feedback.

Ok, i’ve tried and as far as I can go, I get a connection refused in my browser after the
ifconfig usb0

I’ve disabled the firewall but the result is the same
This is quite frustrating.

Hi @Xoff,

I have the Mod-Duo running with USB on Linux out of the box since May… no problem here. I am using Kubuntu-16.04LTS. I am using Firefox.

After plugging in I get automaticly a network device like this:
enp0s20u1i1 Link encap:Ethernet Hardware Adresse 76:5e:0a:aa:ff:ee
inet Adresse: Bcast: Maske:
inet6-Adresse: fe80::8bf5:5e10:7175:cdca/64 GÃŒltigkeitsbereich:Verbindung
RX-Pakete:11 Fehler:0 Verloren:0 ÃberlÀufe:0 Fenster:0
TX-Pakete:51 Fehler:0 Verloren:0 ÃberlÀufe:0 TrÀger:0
Kollisionen:0 SendewarteschlangenlÀnge:1000
RX-Bytes:1024 (1.0 KB) TX-Bytes:11509 (11.5 KB)

Have you tried lsusb? It shows me the following device:
Bus 003 Device 002: ID 0525:a4a2 Netchip Technology, Inc. Linux-USB Ethernet/RNDIS Gadget

Also lsmod | grep usb should give you something like that:
usbnet 45056 2 cdc_subset,cdc_ether
mii 16384 1 usbnet

If you don’t have a module named usbnet: maybe it is unavailable or blocked at your distribution? Try (as root): modprobe usbnet. Does this work? Or take a look at /etc/modprobe.d/* if usbnet is blacklisted in one of the files.

Regards, Holger

OK, it is working now,…but i don’t understand why.

I have a “USB ethernet” in network manager and I have to click on “Connect”…which is what I have done since the first time but this time it works ! :smiley:

And there is a good config now :

usb0 Link encap:Ethernet HWaddr 4E:68:03:3D:A6:79
inet adr: Bcast: Masque:
adr inet6: fe80::4c68:3ff:fe3d:a679/64 Scope:Lien
RX packets:2545 errors:0 dropped:0 overruns:0 frame:0
TX packets:1568 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:3062997 (2.9 Mb) TX bytes:190013 (185.5 Kb)

Thanks for your answers.

1 Like