Left knob long press does not work


I tried long pressing the left knob to access the menu

How to reproduce

  1. Long press the left knob for more than 5 seconds.

Expected/suggested solution

I want to update the software.

Additional information


@benrchn does pressing and holding the right knob works? You should see the banks there…

Have you ever upgraded? When did you get your MOD (what version is it)?

You can also try holding the left knob and left foot switch at the same time then plugin the power cable. This will boot your MOD in upgrade mode.

Hi @acunha ,

Pressing the right knob work.

I am still at the first batch version. (Never updated. I’m late.). I did not find the instruction for the first update.

I tried to boot in upgrade mode but the display was still displaying the MOD logo after a minute. Should it display anything else?

Thanks for your help,

Please see my 2nd comment on this thread:

The included link is a special update image that works for pre-1.0 mods.
You can jump from your initial version straight to 1.0.0 with that update file.

For updating the left knob needs to be fully working though…

Did you try addressing a plugin control to the knob #1 yet?
That will tell us if it’s working or not…

Thanks for the link.

I can assign a control to knob 1 and it works just fine, so the rotation does not seem to be a problem. When pressing I get the mechanical click but it still does not work for accessing the menu.

Is there a way to update through ssh for now?


Any way I can jump to v1 via ssh?

Hello, I also have an early batch kickstarter model, never upgraded, left button long press does nothing – how can I get up to speed with the latest? I read the 1.0.0 release thread and it says to ‘use the 1.0.0 tar’ for people that have never upgraded, but my button does not work, so unable to use the tarball.

Should I follow the instructions here:
and flash the raw image? or would that be problematic?


Hello @ahhdem I’ve PM’ed you.

I think I have the same issue, although my right knob does not do anything either…

Hey guys,
I kind of have the same issue…

After my latest mod (automatic) update, the left knob click stoped working.
Both the long and quick click are not responsive.
The scrool keeps working though…

Any tips/ideias?

Hi Guys, not sure if this is the proper thread. But I’m having the same issue.

My left knob press is not working. One click or long press is not working properly. I can’t access the system menu because of that, or assign multiple functions to the left side. Scroll is working ok.

Build Date: 2020 Jan 10 11:56:28
OS Version:
Kernel Release: 3.4.104-rt139-modduo

Any suggestion? Should I open a bug on GitHub?

Hi @beraldo,

Please send en email to support@moddevices.com and we take it from there!

Please also inform where/when you bought your Duo.

Can you feel the click? Does it click the same way the right does or feel different?


Thanks @Leo_Germani for your reply.

Yes, I do feel the click and it is the same as the right on my perspective.

It was the first ks campaign.

Just sent an email to support with the details.

Thanks again.