Jack Netmanager won't start on boot


Followed instructions given here
Despite existing a /data/enable-netmanager file, when I run systemctl list-unit-files
jack-netmanager.service will show as disabled (that being after a reboot).

How to reproduce

  1. ssh into mod
  2. touch /data/enable-netmanager
  3. reboot mod

Expected/suggested solution

running systemctl list-unit-files should present jack-netmanager.service as enabled.

Additional information

Open the controller menu (hold left knob down), navigate to Info > Versions and write down here the versions.

  • release: v1.10.1
  • controller: F017FF5

Also provide some information about your system if possible.

  • Operating system: Windows
  • System version: Windows 10

I will have a look at this soon.
Though this method is pretty much abandoned now in favour of the USB audio card mode.

1 Like

Would you be so kind to elaborate a little on this?

i think I missed some updates.

Does this mean a Mod duo now is supposed to work as a “regular” USB inteface wen connected to a PC?

It is described on the same page you linked above.
Still to be considered experimental, but yes the target is a MOD unit acting as USB sound card.
(This is sadly broken in v1.10.1 due to a small mishap on my side, tested on Dwarf but forgot to check Duo/Duo X.)

If you want to try it out, I can give you a fixed v1.10.1 build.

1 Like

Probably you mistook me with the OP because I didn’t link any page.

Anyway, I’m not in a hurry to use it, but if this can help testing, I’ll be glad to install the fixed update on my Duo and let you know how it works.

I tried using the usb gadget method, Sink input/output appeared but I couldn’t get any sound from it (maybe because Im on windows?). Net manager method worked with jack on windows

It is because it is broken on 1.10.1. do you have a duo or duox?

duo, sorry for the delay

So I had a look at this. The netmanager issue on Duo is not possible to fix without breakage.
Either it works for units with old 3.4 kernel, or works for units with 5.4 kernel, can’t be both at the same time.
Since this is clearly labelled EXPERIMENTAL in the settings, we will leave it as-is.

You can run these commands on a 5.4 kernel Duo to manually fix things: (but will revert and have to be re-run on next update)

mount / -o remount,rw
systemctl enable jack-netmanager.service
mount / -o remount,ro

With Kernel 6.1.15-rt7 on DUO, is it possible to use this feature?

kinda… but I have seen too many issues to make it worthwhile.

current releases of JACK use packed data structures on x86/64 platforms, but unpacked on ARM (packed is wanted in general, but causes issues with memory alignment on ARM systems).
the difference means that connecting regular x86/64 JACK to the one inside the MOD units (that uses ARM) will lead to random issues due to network packets not following the same exact data structure.

even when both are aligned, I still see occasional issues. so honestly I am for just removing this experimental option altogether.

the push for usb audio interface support seems a much better use of time and efforts, and one that allows usage from any system not just ones running JACK.