I was unable to resolve noise in the Mod Dwarf after trying DI and groundless power

I know this is an issue that’s been discussed quite a bit, but after trying a few things suggested here and here, my attempts to reduce the noise produced by the Mod Dwarf have not been successful. I am wondering if there are other things I can try to figure out if this is a ground loop issue or if the noise is inherent to the device/12 V power supply block. I might also be doing something wrong in the things that I have already tried, so all suggestions are welcome.

My setup: I currently have just the Dwarf connected to a Headrush amp (no guitar or anything connected to the dwarf), with no software pedals active. I can hear noise that is much higher than any other physical pedals I have tried connecting in a similar configuration. Both the Dwarf and amp are plugged in to the same power strip.

Things I tried:

  1. I tried putting different DI boxes between the Dwarf and my amp and hitting the “ground lift” button on the DI box. The amp also has a “ground lift”. Using ground lift in either case did not reduce the noise. One of the DI boxes simply seemed to lower the overall signal level (I checked this by plugging in a guitar).

  2. I replaced the original power plug with one that did not have a ground, and that did not change the amount of noise.

EDIT: 3. I also did try hitting “Compensate Gnd Loop” under Mod Dwarf settings, but that did not fix the issue.

Here is an example of the noise in Mod Dwarf vs Zoom MS-50G, when no pedal is active in either device.

I have been wanting to try a different 12 V/2 A power block, but might need to order one. Do you guys have additional suggestions for what I could try to lower the noise?

Could you make a recording to compare noise from Dwarf and noise from any other pedal that’s not producing noise?

Have you tried with the new feature in Settings → System behavior → Compensate gnd loop?

I did try switching on “Compensate Ground Loop” under settings, but that did not reduce the noise.

Here is a comparison of noise levels on the Mod Dwarf and my Zoom MS-50G (recorded by plugging in output to an audio interface). The first half (~3 seconds) is noise from the Dwarf and the second half is noise the Zoom.

The Mod Dwarf’s noise also “flickers” when I turn the knobs on the device.

Thanks. Do you hear any differences by dimming display backlight?

When the backlight is at 25%, there is a very faint high frequency squeal in addition to the noise you hear in the recording. Raising the backlight value to 100% appears to increase the frequency of the squeal beyond my hearing range.

What happens if you connect let’s say to some studio monitors instead of the Headrush amp?
Have you checked this post from @igor? It’s curious because he was facing a similar issue with a Kemper and he discovered that the issue was with the FX loop of the Kemper and when connected directly the MOD Dwarf had no noise.

I did try different plugging both the Mod and my Zoom (as a control for comparison) into different devices (Headrush PA, audio interface, guitar amp) and the noise persists for the Mod Dwarf. The noise you hear in the recording I posted is when the device is plugged directly into the audio interface. I’m trying to see if I can try a different 12V/2A supply, do you have any recommendations?

The comparison between both devices may not be the most accurate since they probably require different power in order to work, and this may trigger more noise from your setup.
Have you experimented to connect the setup into different power sockets?

1 Like

I agree it’s not the best comparison because the other pedal uses 9V. Ideally, I would be comparing with another device (preferably another Mod Dwarf!) that uses the same 12V/2A power block. I tried connecting to different sockets (at different locations) and still get the noise. At one of the locations, I did get a ground loop issue, which I resolved by using a plug without the ground pin, but the residual noise that I recorded still remained in the signal. Anything else I could try?

What are the input gain and the output gain settings that you are using?

1 Like

My input gain is usually between 10-20% (as high as I can go without clipping) and the output gain is at 100%. Changing the input and output gain does not affect the noise level, so setting the output gain to 100% increases my overall signal to noise ratio.

1 Like

I solved this issue by using a groundless plug adapter with the power supply provided. Hope this helps!

Thanks,. Just to clarify, I already tried to use a groundless plug, and that did not work.

1 Like

100% gain at any stage of the amplification chain is guaranteed to generate noise, even in the quietest, purest of amps.

So it looks to me like your problem is actually between the Dwarf and your amplifier. You mention “Headrush amp”, is it one of their FRFR speakers? If so, those have balanced TRS/XLR inputs, so you’d need balanced cables out of your Dwarf.

From your audio file, I can hear two different noises (sorry, I don’t have the spectrum analyser here to be sure): the electric hum and a digital, high pitched noise – the same you get when watching a movie on an airplane. These two noises have different causes, the latter being most likely a plugin issue, or in the worst case scenario a faulty unit.

The electric hum should have been removed by any of the measures of you have already taken, so please examine your unit while not connected to anything. Plug the AC power and connect your headphones, then move the gain knobs (use different plugins in various combinations). If then noise persists, the ultimate test is to do the same thing at a different site – a friend’s house not to close to you, for instance. That rules out some RF noise or interference in the power line itself. If noise persist in all of these scenarios, then reach out to MOD’s support.


I would suggest you try to lower the output gain and push it on the device after the Dwarf in your chain.
Another thing worth trying out is the (now fixed) ground loop compensation feature on the settings of the MOD Dwarf. If you didn’t yet, please update the Dwarf to the very latest OS and try it out. Let us know if something works.

I want to clarify that the level of the output gain does not affect the noise level. Even when output gain is 0%, I still have the same noise. The reason I set it to 100% is because then the signal passing through ends up being louder than the noise and makes it workable for live jams (but the noise is still too loud for recording). Turning the knobs on the devices does make the noise “flicker”, but does not change the noise’s level.

^Are you talking about the ground loop compensation in Settings? This did not lower the noise for me. Any other ideas on what I could try? Atm, I have ordered a different 12V/2A power supply to see if that helps me.

1 Like

To clarify, the noise appears to be the same even when output gain is set to 0%. I was trying to say that I set output gain to 100% just so the signal passing through is louder than the noise to make it usable for playing live.

I have already tried using the device at different locations, plugging in headphones, plugging in directly into my audio interface. There were no pedals active in the Dwarf (and even no guitar). This particular noise still persists.

There was one situation where I did encounter a ground loop and I easily eliminated it using a groundless plug, but the noise you hear in the recording is always present. I recently ordered a different 12 V/2 A power supply and I will try it out to see if it improves anything. If not, I might need to reach out to support.

Thanks for the clarification.

If in all of these scenarios you had the Dwarf not plugged into anything – be it your amp, interface or computer via USB – except your headphones, then I would recommend you contact support.

Good luck.

1 Like

Yes, I’m talking about that. Have you tried it again with the very latest OS? There was a bug and basically before it was not working even when active. Now it’s fixed.
Let us know if that works now.

1 Like

I tried it with V1.10.3.2360 with “Settings>System Behavior>Compensate Gnd Loop” set to on and the noise still persists. I am assuming this is the latest OS at the moment (screenshot below)?