Gen plugin update problem (DUO X)

I am working on my own plugins made with Gen and it’s great.
However, after I upload the first version of a plugin on the device, I am unable to update it. The only thing I was able to do in order to use a newer version of it, is to give it a new name (for example by adding a version number in its name).
Removing it from the pedal board, then updating it, then inserting it again in the pedal board, doesn’t work, I get the old version.
Uninstalling it, then uploading the new version, doesn’t work, I still get the old version in the pedalboard. How strange ? Would it somehow stay in the memory ?
It’s a bit painful for testing and making quick corrections, inserting the plugin and remapping the knobs over and over.
Anybody has this problem ? any ideas ?
Thanks ,

1 Like

Perhaps this is just a browser cache problem.
If you keep the browser developer console option, under network there is a “Disable cache” option. So in theory this is all you need.

Or do you mean the actual processing is still the old one, not just the parameter names…?

I tried refreshing the browser but it actually is what you say, the processing and parameters on the device are the old ones. Why I am suspecting that deleting on the device does not really delete.