Faulty footswitch?

Seems Footswitches A & C on my Dwarf only want to work about 60% of the time on first push (B is fine). Keen to avoid having to send the unit back. Anything I can look at this end?

I suggest you to email support@moddevices.com if you didn’t yet.
Maybe attach a little video showing us the problem.

@jon: just wondering: are the footswitches in the Dwarf different from the footswitches in the MOD Control Chain Footswitch unit (the one with 4 switches)? those switches have been a bit unreliable – MOD sent me replacements so i could change out a couple of them which became unresponsive in my CC Footswitch. the new ones are fine so far.

Thanks @jon I’ll create a video and send an email (typically when I tried to create a video earlier they worked ok :joy: ) But deffo a bit hit and miss. Frustrating when using the looper for example.

Yes. The footswitches are not the same, as far as I know.

hmm maybe use the looper so we understand what is really happening. It may be the case the the problem is with the looper

I have the same Problem with my spanking new Dwarf (arrived yesterday). Especially footswitch B and C only work about half of the time, which as mentioned, is terrible with the looper, but also occurs with other functions.
I would happily replace them with high-grade products, if the waranty and the physical proerties allow.


Can you write to support@moddevices.com?
Please describe the issue and if possible add a small video showing it.

1 Like