Error building mod plugin builder (multilib 1/1)


I got this error when running: ./ moddwarf
I am using UBUNTU 20.04 on Windows WSL2. Thanks!

[INFO ] =================================================================
[INFO ] Installing C library headers & start files
[INFO ] =================================================================
[INFO ] Building for multilib 1/1: ‘’
[EXTRA] Configuring C library
[ERROR] configure: error:
[ERROR] >>
[ERROR] >> Build failed in step ‘Building for multilib 1/1: ‘’’
[ERROR] >> called in step ‘Installing C library headers & start files’
[ERROR] >> called in step ‘(top-level)’
[ERROR] >>
[ERROR] >> Error happened in: CT_DoExecLog[scripts/functions@376]
[ERROR] >> called from: glibc_backend_once[scripts/build/libc/]
[ERROR] >> called from: CT_IterateMultilibs[scripts/functions@1586]
[ERROR] >> called from: glibc_backend[scripts/build/libc/]
[ERROR] >> called from: glibc_start_files[scripts/build/libc/]
[ERROR] >> called from: do_libc_start_files[scripts/build/]
[ERROR] >> called from: main[scripts/]
[ERROR] >>
[ERROR] >> For more info on this error, look at the file: ‘build.log’
[ERROR] >> There is a list of known issues, some with workarounds, in:
[ERROR] >> ‘docs/manual/’
[ERROR] >>
[ERROR] >> NOTE: Your configuration includes features marked EXPERIMENTAL.
[ERROR] >> Before submitting a bug report, try to reproduce it without enabling
[ERROR] >> any experimental features. Otherwise, you’ll need to debug it
[ERROR] >> and present an explanation why it is a bug in crosstool-NG - or
[ERROR] >> preferably, a fix.
[ERROR] >>
[ERROR] >> If you feel this is a bug in crosstool-NG, report it at:
[ERROR] >> Issues · crosstool-ng/crosstool-ng · GitHub
[ERROR] >>
[ERROR] >> Make sure your report includes all the information pertinent to this issue.
[ERROR] >> Read the bug reporting guidelines here:
[ERROR] >> Support
[ERROR] (elapsed: 3:52.81)
[03:53] / make: *** [ct-ng:261: build] Error 1

I have advanced (there were some dependencies not resolves). Now I get:
ERROR: No hash found for fftw-3.3.8.tar.gz
–2023-09-22 21:04:58--
Resolving (…,,, …
Connecting to (||:80… connected.
HTTP request sent, awaiting response… 404 Not Found
2023-09-22 21:04:58 ERROR 404: Not Found.

Have you tried ./bootstrap moddwarf-new ?

Hi! I was able to compile it at the end.The main problem was that there are some libs that were not available at the site so I had to download them manually.

Then the fftw had no hash so I had to deactivate hash check for that.

Now I am trying to figure where the source for the fuildsynth plugin is downloaded because I want to change a couple of params.


In the plugins/packages folder there will be the fluidsynth folder with a mk file, this references the git repo

@micahvdm Can you please help me some more with this? I could compile the plugin, but I am confused. I used: ./build moddwarf die-plugins

This downloaded the 1.1.6 tar.bz2 version of fluidsynth from sourceforge, but this looks obsolete to me. Then it compiled and run fine, but it says 2.2.0 version while the official mod website uses the 2.2.6

Then there is this repo: GitHub - DISTRHO/DIE-Plugins: DISTRHO Imported Effect Plugins
That looks like the code I should be using, but no idea where to start.

Thanks for your time.

the die-plugins does not use fluidsynth as external library/dependency, there is a version already included within its sources.

and yes, you just need ./build moddwarf die-plugins if you want to build it within mod-plugin-builder, nothing more needed except maybe ./publish moddwarf die-plugins to get the build into the dwarf unit.

since you want to tweak the code of the plugin, the easiest is to import the MPB environment for use in local builds. basically something like:

# import MPB cross-compilation setup for dwarf
source /path/to/mod-plugin-builder/local.env moddwarf

# change dir to where die-plugins source is located
cd /path/to/die-plugins

# build it

# deploy to unit
tar -C bin -cz distrho-a-fluidsynth.lv2 | base64 | curl -F 'package=@-'

@falkTX Thanks for the help. I was able to compile it, but when installing it does not copy the modgui required files.

I tried adding them manually (from the original version) and it showed on the plugin explorer, but when trying to add the plugin to the pedalboard I get an “error adding effect”.

I checked the .lv2 folder on the dwarf and it got all the required files (the .so, the ttls, and the modgui folder).

What am I missing? Thanks again!

P.D: I tried replacing only the .so file and that is not working, so there is some problem with the library that is generated :frowning:

GOT IT!!! When using moddwarf-new it just Worked!!! I have been able to change the polyphony to 6 and it works! Thanks all!!!

That guarantees CPU usage on MOD Devices. I will add a control to choose how many polyphony based on song.


This platform is just awesome :smiley: