[Dwarf] USB MIDI dropout/stops working


The unit will stop being accessible through USB MIDI. The web editor will either say “Bug!” and can’t access parameters or something like that. If I try to refresh the page, it will not load at all, just like if the unit was not connected.
It will also stop being recognized by the computer, and will be gone from e.g. MIDI output destinations in DAWs.
The unit does not freeze or anything, and it’s still working as expected. It has the same effect as pulling the USB cable.
So this is more of a nuisance than a serious problem for my use case, but would be nice to have it be more stable.
Taking the USB cable out and putting it back in solves the issue until the next time it occurs.

How to reproduce

I’m not entirely sure, it seems to happen at irregular intervals. Usually there’s nothing specific I can think about that has happened prior to this issue.
It has happened both when I’m doing stuff with it, and after I haven’t done anything in a while.
All other gear connected to my computer behaves as expected, I’ve tried a different USB cable, tried using different browsers for the editor, anyhthing I can think of, really.
There is of course a possibility this has nothing to do with the dwarf, but considering it doesn’t happen with any other piece of gear, I think that’s unlikely.

Expected/suggested solution

It stays connected to the computer as long as it’s powered up and the USB cable is plugged in.

Additional information


Also provide some information about your system if possible.

  • Operating system: macOS 11.6 Big Sur
  • MacBook Pro 15" 1st gen touch bar 2016

This is, in theory, also fixed in the beta build I sent you in PM

1 Like

Okay, cool! I was in two minds whether to post this or not before trying that out, not being certain that would be covered. Thanks!

1 Like