Dwarf reset to factory defaults stuck on "

Dwarf factory default system restore using image moddwarf-v1.13.3.3259 .tar and instructions from ttps://wiki.mod.audio/wiki/Factory_Reset_Images is stuck on “CHECKING FILE”. I’ve powered down and tried several times with the same result. I had no trouble copying the tar file to the drive on my macbook, and the dwarf finds the drive and the file. But then it just hangs on “CHECKING FILE”.

I was sure I’d seen this addressed on the forum but I can’t find the post.

What am I doing wrong?

how long did you wait? there could be 10 minutes for the whole update, it is much longer compared to regular installs.

It’s still not finished, and the time stamp on my post says 1 hour ago.

Fortunately I still have my duo, but unfortunately I have no gigs.

At this point I think I’ll just ssh in and do it manually if I can find out exactly how to do it. I’ve done it before, just can’t find the instructions. I’ve probably got them printed out somewhere around here. I’m in right now - already had passworldless ssh set up… Keys, known_hosts, etc, so I don’t have to remember the password.

Like I said, no gigs, but even if I did I could just pull out the dwarf and put in the duo.

I’ll get it done.

I’m really screwed now. I’ll try again in a few days and if I absolutely have to I’ll pull the cover and short the pins. I really hate to do that though.

there is never the need to do that on a dwarf unless it cannot enter recover mode manually.

press and hold right knob and button while powering on the unit to enter the maskrom flashing mode.
as per Troubleshooting Reinstall Dwarf - MOD Wiki

why it gets stuck I do not know at this point sorry

1 Like

Thanks! I’ll do that today. I’ll just pull the Dwarf off the board, put it on my desk with nothing attached, and start over.

Yesterday was a bad day all around and I was getting more than a little frustrated with everything and it spilled over into my dealings with the dwarf.

I’ll figure it out.

Thanks for all your help!!!


Sending positive energy your way.


I need a good bowl of veggie soup right now.

Already working on cup of fairly weak “low acid” coffee with soy milk. I dumped the first one. I sound like a real wuss, but TFS. Beats the hell out of another trip to the ER. Or just a trip straight to the morgue, as I suggested last time to the EMS guy who was poking needles into my arm.

“I’m not dead!”

“…you’ll be stone dead in a moment.”



I finally gave up and vnc’d to my linux machine and went through the whole procedure again.

“Now back to our regularly scheduled programming.”