Dwarf not responding to snapshot change PC

I’m attempting to use a MusicomLab EFX-LE effects switcher to change snapshots on my Dwarf, but the Dwarf isn’t responding.

I have six snapshots, Pedalboard Change PC is off and Snapshot Change PC is on channel 1. I assumed that the six snapshots would be assigned to PCs 1 through 6, and the EFX-LE is sending PCs in that range. The Dwarf doesn’t respond at all; whatever snapshot I have loaded is the one it stays on no matter what PC I’m sending it.

I must be missing something but I’m stumped.

1 Like

I’m assuming you’re using 5-pin DIN to 1/8" TRS Type A adapters to connect the EFX-LE to the Dwarf. Do any other midi functions work using those cables/adapters?

1 Like

Have you set the midi channel correctly in the settings?
The Dwarf recognises PC commands on 2 different channels. One for pedalboard changes and the other for snapshot.


Also note the web gui needs to be closed for these to actually do anything. (USB cable can still be left connected to the PC)


Thanks for the responses everyone!

@malfunction54 Yes, I’m using 5 pin to 1/8". I’m also using a MIDI Baby for tap tempo/triggering the Stuck plugin; the Baby is currently sending MIDI over USB, but I was using the 5 pin cable when programming it and it worked fine. Only the EFX-LE is having this problem.

@Sharry Pedalboard Change PC is off, Snapshot Change PC is on channel 1.

@falkTX Dwarf is completely disconnected from my computer.

1 Like

And do you have the MusicomLab EFX-LE sending via the same channel?

Yes. EFX-LE is sending PCs on multiple channels, channel 1 among them.

So actually that may exactly be the problem :slight_smile:
Probably the MIDI channels implementation is different between devices.
The Dwarf is from 1 to 16 and maybe the EFX-LE is from 0 to 15.

To be sure if this is the issue try to set a channel 1 number lower on the EFX-LE (so in your case try with channel 0).

Let me know if that works.

1 Like

Double-checked and the MIDI channels 9n the EFX-LE are numbered 1-16 like the Dwarf.

I also turned off all other MIDI PCs on the EFX-LE so it’s only sending on channel 1. Still no luck.

Do you have another MIDI-Instrument where you can proof that the sent signal is correct?
I’de use for this a “MIDI Distributor” like
Kenton MIDI Thru 5 – Thomann

1 Like

@Sharry’s idea is good.
You only need a MIDI monitor. Try out this one.
Please note that you will need to use Chrome and first connect the controller and just then open Chrome and load the website.

@jon @Sharry Thanks, I’ll give this a shot tonight. The EFX-LE worked fine sending PCs to my Source Audio pedals so I think it’s sending the correct messages, but it won’t hurt to check.

I can also program the MIDI Baby to send PCs, I’ll try with that as well.

1 Like

Maybe you already tried this, but I would also try to set the MOD Dwarf listening to one channel before.
I quickly check the manual of the EFX-LE and despite they saying there that you have 1 to 16 it may be worth trying.

1 Like

Alright, I finally got everything working as intended. Gonna chalk this one up to a couple of user errors.

When I hooked everything up to check the MIDI signals, I noticed the Dwarf’s snapshot change channel was on 2, not 1. I had set it to 2 a while back but had changed it to 1 more recently; I’m not sure if the change just didn’t save properly or if I changed it back to channel 2 later on, and got mixed up when updating the presets on the EFX.

I also realized that my input gain wasn’t set correctly for one of the snapshots I was trying to load. The board I set up has an envelope filter at the front, and at some point I lowered my input gain to try and troubleshoot some unrelated tonal issues. The lower input gain changed the response of the filter, making me think it wasn’t active when I pulled up the snapshot.

I’ll report back in if anything unusual happens (have a couple gigs coming up so the Dwarf will see plenty of use), but for now I’m calling this one solved. Thank you for all of your help!


All’s well that ends well :slightly_smiling_face:


I’m glad that you managed to get it working.

You’re welcome and please do so :slight_smile: