DWARF frozen

Hi there

I kindly ask you for a help because I couldn’t find out the solution by myself

Yesterday I was messing around with the pedalboard I had set it up, trying different wah controlled by an LFO, on the GUI (windows)
When I had found the best settings, I tried to save the new pedalboard and the message ‘you can’t save because a bug’ or something, appeared on the PC. Tried few times, always same message. Then I tried to upload a previously saved pedalboard but no connection to the dwarf, I could do anything
So I checked the dwarf out: input 1 (guitar input) was ok, green led turned on but no output at all (leds always off)
Dwarf’s screen was on but the controls onboard were frozen, as well. No action from switches, buttons, rotative controls
I disconnected the chocolate mini pedalboard and the PC connection and turned it off, few seconds, on again. Same scenario
Today I turned it on again: it boots up, gets frozen, no GUI connection
Tried the ‘restore boot’ (left switch + left rotative control pushed down simultaneously, 5 seconds long while switching it on) but no result: again same scenario

Is there the way to go for a factory reset using the onboard controls? I haven’t found it out
I have to say I’m short in software/programming skills

Thank you in advance, guys

It’s locked in this appearance/mode

Could this help?

Or move the file.


It could be the reason for that
Sorry for the maybe stupid question but what is it the ‘ssh’?

Pratically I can do anything with the dwarf, neither on the web GUI (no connection) nor on the device GUI (useless or fronzen controls, all of them)

That’s why I was thinking about a factory reset procedure during the boot. Or something else via USB port?
I’ve no clue…

1 Like

Think that would be a useful attempt since I had similar problems at the time.
The technical is quite simple ^^ to accomplish see for example ssh(1): OpenSSH SSH client - Linux man page, rm(1): remove files/directories - Linux man page, mv(1): move files - Linux man page.
But wait until someone from mod.audio gives answer.
I am not an oficial employee.

1 Like

SSH is a method to log into the machine directly instead of through the web browser. It is not something for beginners, but something advanced to debug the device. Depending if you are on Windows, MacOS/Linux you will need a different program/command to gain access and delete the suggested file.

If it’s not possible for you to do this advanced step it could be possible to do a factory reset instead, however then you will lose all your settings and saved pedalboards.

Did you use a Beta plugin on this patch? or did you use only plugins from the main store?

1 Like

Hi Dreamer

Only from the main store
Another detail I’ve noticed in the evening is that, during the boot, immediately after the big writing DWARF disappears, in the left/bottom corner, 1/0 changes to 1/1 and then it got bricked. Maybe is relevant

What is the procedure for the factory reset? I can’t see any other option right now and, fortunately, I just saved the setting on the memory stick half an hour before it stopped working
But I guess I’ll loose the plugins I’ve paid for

No, the plugins are attatched to the dwarf serial number, and if needed @jon could manually help you on this. But first you dwarf has to come back to life !

  1. Copy your backup now on your usb stick to you computer (just in case)
  2. Download the full dwarfOS here : Factory Reset Images - MOD Wiki
  3. Follow these steps : Troubleshooting Reinstall - MOD Wiki

Is this helping ?


I’m happily back

First of all, I admit I couldn’t put the dwarf in the restore mode because I pressed the left button instead of the bottom-left switch… my bad

From there I followed your instructions, went through a factory reset images uploading, which has unlocked the dwarf then I’ve uploaded the latest firmware release. Web GUI became accessible so I’ve uploaded my settings via USB memory stick

Can’t test it with the guitar right now but the onboard controls are working fine now

I’m really greatful for your support, many thanks guys!

And if there are guitar players out there, give gxcrybaby a try, with the width controlled by a AMS LFO 2, sine wave, in sync with the song time



Glad you got it to work and that you had a recent backup! Of course lets hope it doesn’t happen again, but if it does maybe it can be more easily reproduced and we can confirm a specific bug that needs fixing.

Otherwise: enjoy your Dwarf!


Thank you Dreamer

just in the case, I’ll try to collect as many details as possible to fix the bug
Greetings from the (today) sunny north of Italy