Duo X Blank Screens after Upgrade to Firmware 1.10


After upgrading to firmware v1.10, both screens on my DUO X are brightly lit, but blank. I didn’t note what version I upgraded from, but this is my first firmware update since early 2020.

The symptom persists through reboot. I have not tried changing screen brightness and contrast settings, because I am not sure how to do so without using the screens. There is checkbox on the “Advanced” tab of the MOD Settings web page to automatically restart the screen controller, but this doesn’t seem to affect the problem at all.

Aside from the display issue, the device appears to work correctly.

How to reproduce

Reciting this from memory because I don’t know how to go back and repeat the install:

  1. Power on device with old firmware and connect to laptop via USB.
  2. Open the device webpage in a browser on the laptop and note the “please upgrade firmware” prompt.
  3. Click through the upgrade prompt and wait for device to reboot.

Expected/suggested solution

I expected the screens to function normally.

Additional information

Here is what I see on the System Information tab of the web interface:


  • Buffer Size 256 Frames
  • Sample Rate: 48000.0 Hz
  • DSP Load 9.3%
  • Unit: MOD Duo X
  • Build Date: 2021 Aug 02 11:15:37
  • OS Version
  • Machine: aarch64
  • Release: 4.9.123-rt125-duox
  • Version: #5 SMP PREEMPT Mon Aug 2 11:12:56 UTC 2021

I’m accessing the DUO X from a Linux laptop using Ubuntu 20.04

Thanks so much for the help. I really love this device.

This looks as if the controller firmware failed to update.

Please do the following:

  1. boot up the device
  2. open web ui advanced settings
  3. in dangerous, reflash: type the word “REFLASH” in the linebox and press the Reflash button
  4. in dangerous, cleanup: tick the “Clear device settings”, type “DELETE” on the linebox to confirm and press the delete button

Thank you again. This resolved the issue. The screen remained blank during and after the reflash, then began functioning normally after I cleared device settings. I really appreciate the help.


Hi, how long did the reflash take? Im sitting here for 30 min and the mod doesnt seem to do anything after I hit REFLASH. The web page doesnt load anymore, but im too afraid to restart the unit… Pls help soon.

1 Like

It shouldn’t take that long.
If it keeps happening, please write to support@moddevices.com and add the serial number of your device.


Hola Jon, I still have the problem not being able to upgrade to firmware v1.10, nor go back. My unit is still firmware broken as far as it seems.
You said to PM you, but I can’t find the PM function.
Would you mind telling me?
Thank you very much in advance!
Have a good start into the week.

Hello @nomilian,

Can I ask you to send a message to support@mod.audio?
We should take it from there. Please include the device serial number and any reference to our previous conversations.
This will help me help you solve this issue.

Would you share how the issue was solved ? I’m afraid I’m in a similar situation…

Hi, I discribed the problem via Mail and was able to give my device to the Mod team for further checking. Now it’s there and being checked. I don’t need it right now, so I told them that there is no pressure.
Good luck with your device!