DISTRHO - DIE Fluid Synth

Can you give me some details about that? I try Mindi, but I don’t know what channel/messagge type/ note/number and value use to change the current sound of a multibank sf2…

P.s. the reverb and chorus part doesn’t work for me…

Reverb and Chorus depend on the sf2 file, some provide no reverb at all, some provide a lot.
So the reverb/chorus details will vary depending on which sf2 file you have loaded.

For the program changes I have not tried this myself on MOD to be honest, but I know MIDI program change messages supposedly works. Can Mindi generate those? Finding out the correct program number to set might be tricky for some non-GM soundfonts.

Yes it can :wink:

Maybe the Fluid Synth is a good one for the priority list on documentation. I’m being quite busy, but I actually would really like to help with that. It would actually help me getting better knowledge of the plugins :slight_smile:

When I use the DIE Fluid Synth plugin by loading a Soundfont (.sf2) file, the Chorus effect is always enabled in the On or OFF position.
If I change the effect from ON to OFF or if I modify the parameters (Speed, Depth, Level etc.) it does not change anything.
I do not encounter this concern with the Reverb effect.
I tested with 2 different keyboards, about twenty different Soundfonts (Piano, Celesta, Synths…) for the same result.
Unit: MOD Duo X
OS Version:
I just noticed that the problem does not come from the Chorus of the plugin, but a problem on all “FLUID” plugins.
When I load any FLUID plugin (FLUIDGM Pianos, FLUIDGM Strings and all others) there is this sound issue. It sounds like a Chorus, but maybe it’s more like the keyboard’s Mod wheel is on all the time.

1 Like

This may be an issue with your MIDI controller. We were not really able to replicate.
Can you tell us which controller are you using, send us a sample sound of the behaviour and the particular pedalboard where this is happening?

1 Like

Hello, thank you for your feedback.
I’m just trying several things. I wanted to know if it came from my keyboards (Akai MPK88, M-AUDIO Keystation and Arturia MiniLab), so I just tried the MIDI Generator in a FLUIDGM Piano effect (see screenshot), and I have the same result, always this modulation effect (like a very loud chorus, or the Modwheel).


Can you send us a sample of what you are mentioning?
A colleague of mine tried and he couldn’t notice it. I tried it as well and couldn’t notice it either, both with a controller and with the generator.

1 Like

Are you by any chance using MIDI CC#1 somewhere? This is the default MIDI CC for the modwheel, and it indeed sounds like the modwheel is not set to 0.

What happens if you put MINDI in the pedalboard and make it send 0 on MIDI CC#1 into the fluid synth?


With FluidSynth there is no problem (it seems to me, because the sound is not precise enough), but with the FluidPiano it’s always the same problem. With my controller and with the MIDI Generator.

(PS: No using MIDI CC#1. I had tried to deactivate it on my controller and to change parameters but the sound was always with this modulation.)

1 Like

Can you try using this pedalboard please?

Just play some MIDI notes from your external controller, and change the value param on MINDI. Please let me know if setting value to 127 gives you the heavy modulation sound, and setting it to 0 gives you the sound with no modulation.


I just uninstalled the FluidFXs that were giving me trouble, turned off the MDX, reinstalled the FXs, it works fine with my controller and the MIDI Generator…
I don’t understand, but it works fine!
I’m still going to try the Pedalboard (thanks :wink: ).


Glad you got it working, very curious about the source of the problem though. If you manage to find out how it happened we would be very happy to know!


OK, maybe I have an idea, I’m doing my tests and I’ll send you the answer. Thank you for everything !!! :wave:


I didn’t understand everything :thinking:, but here’s what happened:
In fact it is my Akai MPK88 controller which sends a signal to the MDX which is interpreted as a modulation effect. But as I had disabled MIDI CC#1 for the modwheel (and in this case, the wheel was indeed inactive), I couldn’t find it.
By using the MIDI Event Filter plugin, if I block the Program Changes, this modulation effect is no longer engaged.
I looked at all the settings of the controller, I did not find what was wrong, what was and where this signal passed … :neutral_face:
So I block all parameters except CC and Notes, and everything works correctly (notes, sustain pedal etc) :champagne:.
Thank you again for all.


Thanks for sharing your findings, I will do some more research into why this happens exactly when I get some time!


Is it normal that playing only a few notes eats up CPU very quickly? ive loaded a fairly small (20mb ish) sf2 piano file and with only a few notes it starts to glitch with the cpu spiking 100? any ideas? are sf2 files not made equal? (i have idea about the internal working of an sf2 file)

1 Like

ok…you answered me on the heaviness of the file.
Have you tried to mess around with the plugin parameters?
I can’t remember now what was it (I think reverb) but some parameter when in high values was turning the plugin heavier (if I don’t mistake)

1 Like

Ok, I hve tried out the DIE Fluid Synth on my Dwarf, seems to be working fine.
A couple of comments though:

  1. Whenever I upload a new sf2 file wth the file browser, the plugin does not pick it up (i.e. does not ‘see’ it) until I delete the plugin from the pedalbord and add it back again. I think if you add a ‘reload synth list’ button in the settings window of the plugin, it would help.
  2. The plugin doesn’t seem to be midi-guitar-friendly: I’m triggering the plugin with my midi guitar pickup + Axon midi converter, and the plugin responds to pitch bends within a very narrow range. Midi guitar synths (like my good old GR-33) are usually capable of treating pitch bend cc values (-8192 to 8191) as 0, 1, 2, 4, 5, 7, 12 and 24 semitones.
    Now that I think of it, this may be not the plugin setting per se, but the global, device-wide setting. Is it possible to add something like such setting? Otherwise one of the main features of having a midi guitar as a controller is kinda lost…
1 Like

Hi, I saw this in the model module of patch box on the raspberry pi. Please can you help me find the location I need to place SF2 files so that they appear in the file selector on the plugin’s gui?