Controller keyboard connected to the USB port of the Mod Duo X


I connect the controller keyboard to the USB port of the Mod, with a synthesizer bank, I don’t get sound. If I connect the controller keyboard to the PC, using the MOD as an external instrument in a Daw, it works fine.

Is it not possible to use the Mod with a keyboard connected to the USB port?


1 Like

Nobody knows what i do wrong?

To be honest, I do not understand what you are trying to say.
Can you reformulate your sentence?

1 Like

Is it not possible to use the Mod with a keyboard connected to the USB port?

Yes it is possible, I do it all the time.

I connect the controller keyboard to the USB port of the Mod, with a synthesizer bank, I don’t get sound.

A controller keyboard does not make sounds, it generates MIDI notes.

You need to assign the controller keyboard port to a virtual MIDI pedal. Many of the virtual pedals in Mod Duo are generators. This means that they take MIDI notes as input and will generate sounds on the output.

Make sure that the port of your controller keyboard in the Duo’s “MIDI Port List” is checked so it appears in the pedalboard as an active MIDI port (left side of the screen).

MOD connected to a midi keyboard works well for me. Check the midi channels you are using. Maybe the keyboard is sending on a different channel than you expect. Or maybe your patch wiring is wrong. Or maybe you use the wrong USB port…

Thanks for answering, my English is from Google’s translator. Sorry

Let’s see if I explain myself.

I connect my M-Audio keystation Mini 32 to the USB port of the Mod Duo X, select, in Banks a pedalboard Synth, for example Synth Acid, and I have no sound.
In System, Pedalboard Nav Midi CHN I have selected all the channels and I have no sound
Curent Pedalboard only shows Save State and Reset State.

But if I connect the 2 MIDI ports of the Mod, to the 2 MIDI ports of the RME sound card, and the M-audio to a USB port of the PC, configuring the Mod as an external instrument in a Daw, it works fine, I can even pedal new on the Mod Devices website.


In short, my controller keyboard (which does not produce sounds) is active connected to the midi out and midi in ports of the Mod. Connected to the USB port, it does not work.

1 Like

Hi Lant,

To see if everything was working properly, today I tried to connect a M-Audio air Mini 32 to my DuoX.
Sadly it did not work either, which is odd because it does work fine with the MOD Duo.

Probability there is something going wrong with the DuoX in combination with these specific keyboards (might be some drivers).
We will investigate things further and address this in a future update soon!

sorry for the inconvenience

1 Like


Arturia KeyStep funciona en Mod Duo X?

I am going to buy a new midi controller keyboard. I like Arturia KeyStep, but I can buy another one tested in Mod X.
What midi controller keyboard have you tried working on Mod X?

Sorry to jump in here.

Does it mean the Arturia Keystep doesn’t work with the Mod Duo X in general?

Right now, over USB probably not.

The nice thing about the Keystep though is that it has DIN-MIDI as well, which will work (and in the future with the CV’s too :slight_smile: ). Since its working on the MOD Duo it should be able to get working with the MOD DuoX as well, again its most likely a driver issue (luckily there is @falkTX performing his Linux magic :mage: we will be addressing this soon! ).

1 Like

weird, i used my keystep over usb a while ago perfectly with the modx. maybe it broke with a newer firmware… will give it a try soon…

cheers max

oh, then it might be that the Keystep does not fall under this ‘Arturia DuoX bug’, good to know!
Since we do not have one here to test I did not want to make any promises we can’t keep :wink:

I just acquired Arturia Keystep and it works correctly,connected to the USB port of Mod X

1 Like


Late to the show… Just testing an M-Audio Axiom mini Air 32 via USB to my Mod Duo X and it does not work.

Was having a browse at the shell (not novice to linux), but couldn’t find an lspci -v to check the kernel detects it… did execute an lsusb before and after connecting it… sees the hub, not the Keyboard it seems… I can see this is a minimal linux built on busybox… just curious about the dev tools available here

PS: where is the main log for checking these type of things at shell level?

I got myself an m-audio keyboard just to be able to test this, and I can reproduce the issue.
Tried a couple of things, but nothing that made a difference.
Will continue investigating…

I have the smallest akai mpk keyboard that also does not seem to work. My thoughts were that it was because it needs to be powered via usb and maybe the mod duo can’t do that? I’m talking about the Duo not the Duo X though, sorry.

It can, that is not the issue.

I investigated a bit, but it is a lot more tricky than I was expecting.
It is an incompatibility with some devices when “downgraded” from usb3 to usb2 (at least that is my theory).
The m-audio keyboard I have here which does not work on the Duo X right now, also does not work on the PC USB3 front ports, but it works on the ones in the back… (it works on any usb2 port too)

The Duo X usb host is internally a usb3-capable driver, but since we only need usb2 we do not enable usb3 related stuff.
The curious thing is that the error message printed by the Linux kernel on both my main PC and the Duo X is very similar, leading me to think the issue might be the same

Anyway, this is all too technical probably.
We will keep trying. Sadly some USB MIDI devices do not work just yet, sorry about that.