Changing the SSH Shell

Not sure if this is the default, but my Dwarf would run sh shell upon login as root.
sh does not seem to support history, so my up arrow never allowed me to pull up a previous command … frustrating.

I found a tip that seems to work:

I created a ~.profile file which contains

export SHELL=/bin/bash
exec /bin/bash

And now upon login I am left in the bash shell, which does support history.


Missing history is there by default, enabled by a few steps.
See Access MOD using SSH - MOD Wiki