Can't try new pedalboards anymore

I’m connected to my ModDuoX via the web interface. I can make, load, and save pedalboards from the web interface. I’m running v1.10.4 on the ModDuoX
What I can’t do anymore is load new pedalboards through interface at
This is the message I get:
Installation failed! Please make sure your MOD Duo is connected so you can access the UI from this same browser. Also you must be running the latest release.

I’m using Chrome 94.0.4606.61.

Does anyone have any advice?

This issue is bowser related.
We are searching for ways to fix it, but right now the biggest problem is to find an effective way to reproduce it (so we can fix it).
Does it happen if you experiment with another browser or incognito mode?

1 Like

I get the same error in incognito mode as well as in the Edge browser.
Everything was working fine until a few days ago in Chrome.

Thanks for looking into this! :wink:

Are you on Windows or Mac?

I use an iPad for my recordings and just stick with safari browser for the mod GUI.

Have not had an issue with it at all. Maybe another browser?

Have you cleared your Chrome cache and cookies?

Same here: “Can’t authenticate with Cloud to access plugin store”
Running latest firmware, tried Chrome, Firefox and Safari on OSX Catalina. No success… I cannot update or upload any plugins.

I’m on a PC.

Oh, that is quite different then.
If there is no authentication happening, then updates and plugin downloads are not possible and everything in between that requires talking to the MOD Cloud.

Since this is a Duo X, I imagine it was working at some point.
Maybe is blocked on your network?

Does this URL work for you?

1 Like

I am able to use the store. The only thing I can’t do is download pedalboards.

The link takes me to a bunch of text. Is that what it’s supposed to do?

I was referring to not being able to access/authenticate the device, we are having 2 discussions here on the topic.
(and yes, it is expected to see a bunch of text, means the connection to the MOD Cloud works)

For your case @Andrew_Bellware I think it is a case of browser updates restricting actions.
Do you have any other browser other than Chrome and Edge? (Edge is pretty much the chrome engine with a different integration, so it is expected to behave very similar.)

I often use Firefox myself, and that still seems to work.

You are not the first one to mention that this integration has issues, seems to be more common the last few weeks…
We will investigate this soon, the pedalboards site needs update anyway to replace the hardcoded “MOD Duo” text.


I switched to Firefox and it worked. (I didn’t realize that Chrome, Edge, and Opera all worked on the same engine.)
Thanks for your help!

“Victory! Your MOD Duo is now loading the pedalboard you picked… Rock on!”

Good luck @Digiframe ! Hope that works out for you.


This problem could be due to bad behavior from adblockers. Even in incognito mode they could be interfering. The fact that you tried a new browser and it worked right away also makes it more likely to be the case.

If you can go back to your original browser and disable any adblocker and let us know the result.

Anyhow, I’m glad it worked!


I don’t actually have any adblockers installed. It fails with Chrome and Microsoft Edge. It works with Firefox and (surprisingly, to me) Opera.

Glad to hear you have it working Andrew! Yesterday I brought the Mod Duo X home (the faulty one is of the Conservatory where I work) to check and compare with my personal owned Mod Duo X… The personal Mod is working fine and has the sign in the bottom right screen that it is connected to the cloud. The faulty one keeps giving the sign to ‘reload connection’ in the bottom right of the computer screen; so this one cannot connect to the cloud.

This gives me the impression that the Mod Duo X is faulty; it is new out of the box and could not connect to the cloud. You can compose your own pedalboard with everything in the unit, but cannot load external pedalboards or update the pedals in the shop.

I have been able to update the firmware to the newest version, but still no luck… my students will not be able to use it to its full potential; should I return it and ask for a replacement, or is there still an option to try… Thanks!

Also changing the browsers did not help… Firefox, Chrome, Safari. I’m working on OSX Catalina

Send me a PM with the unit serial number and I will investigate what is wrong with the unit.

This is expected, authentication issues are something different than what was being discussed here initially.