Can't stop looping :-). Thanks to LP3

End of day 3. I wanted to go to bed so much earlier… but I can’t stop looping with LP3! :slight_smile:
Looping with Laptop or IPad can be much deeper but I love the raw power of one device doing it all. Dwarf, headphones, Instrumentcable, a powerplug, a violin, maybe tomorrow a microphone & cable :wink: thats all I need. LP3 is inspiring and great for developing ideas! @looperlative Thank you!!!

11 Likes

You’re welcome. I’m working on the more advanced version. I know about the sync request, but if there is anything else, please feel free to make suggestions.

10 Likes

@looperlative Yeah, such a good feeling, having you around chatting with us!
I’ll take it slowly. Normally I have 100 ideas at once, but I will try to focus on the strong ones.

Could you make the Undo function react while recording, so that you kill a recording, while playing awfull stuff ;.-). Otherwise the recording starts first one time and that is irritating.

Would be nice to add a workflow where you can set a fade time that will be activated after pressing undo for the disappearing audiopart before really killing it via undo.

Ah, and did I allready ask for disabling live monitoring? If I have several LP3s only one should monitor audio. Otherwise loudness increases, but drops when playing back…

5 Likes

Hi @looperlative
Do you mean a new looper plugin ? Or are you talking about improvements for the LP3 ?

It would be nice to have the possibility to use the same control for undo and redo with double tap or long press for the latter. I’m talking about the dedicated undo control, because the minimized one, for obvious reasons, only allows one level of undo/redo. Unlimited undo and redo is a nice feature that is not generally present on hardware loopers (at least the ones I tried) and it would be nice to be able to assign that to one button.

I thought about something else but it depends on what is doable on the MOD UI. Is it possible to have the slots containing loops appear in bold characters ? Or any other visual idea that let us know when a loop is present ?

2 Likes

Ooh must try. I found the old looper on my duo x glitched too much at loop point. So I brought a Boss pedal. Really must reactivate my Duo.

2 Likes

I’m always doing both.

This is certainly possible. Keep in mind that when using long press or double tap, that the function will now be triggered at the release of the button instead of when it is pressed. This means that if you want the undo or redo to happen at an exact time, then the individual buttons are the only way to do it. This is always the challenge of all loopers. There is always a need for more buttons.

4 Likes

Do you have a dedicate UNDO button or are you asking for something different?

1 Like

@looperlative Dedicated undo button. I use the trigger for that on the right knob. Its easy to hit that with a foot ;-).
It works that way when overdubbing, but not when recording first track, first loop.

1 Like

I didn’t know you were working on another looper plugin. Can you tell us more about it ? I was about to buy the LP3 but I might consider waiting for the new one depending on its special features.

Damn, I didn’t think about it. That’s still not as problematic as with the loop recording anyway. Maybe that could be an additional Trigger Function (undo/redo), which would be a way not to mess up the existing UI and UX. Sorry, I’m just realizing that I’m asking you to work around the limits of my Chocolate MIDI controller. :slight_smile:

1 Like

At this point, I don’t have a firm plan. I’m not sure what is going in it and I don’t have a release date.

If you can afford it, I highly recommend the controllers from Morningstar Engineering: https://www.morningstar.io/

4 Likes

Thanks for the piece of advice but I’m not considering buying an expensive MIDI controller. I think I’ll buy the LP3 and try to get the best I can out of it with my cheap Chocolate controller. Furthermore, your plugin seems complete enough to satisfy my needs. I may bother you with questions or requests about some details though. :slight_smile:

Like the one about differentiating full and empty slots.

1 Like

This one is already in the LP3. It is the output mix. If you set output mix to Wet Only, then you will only get the looped audio.

5 Likes

A change for this has just been released today. Upgrade and undo can now be used to erase a running recording.

10 Likes

@loooperlative
Ah, found the output mix!! Great! Undo works now while recording first take!

I had other ideas… Now I can use multiple Loopers in parallell and I ask myself if it would be possible:

  1. To make a button which selects the active looper, so that I’d just have to select the looper I want to work with (with one button +) and then use the allready set buttons to control thisone.

1,5. Ok, maybe it makes sense to have another 2 buttrons for each added looper (one for record/stop…) and the other one for undo, although undo could also be depending on ‘active’ looper…

  1. This one would really make sense: Use the Track selector for each LP3 instance in parallell, so that each instance changes active Track, when pressing, so it would be just Undo button & record … button to add for each added Looper.

… I still have to test, just ideas …

Thank you for the update!

2 Likes

@MCCY Unfortunately, the plugin platform doesn’t allow that. If you instantiate more than one looper, they each have independent controls. The only reason that you are required to set a looper number is to differentiate file storage. Unfortunately this was necessary as the plugin host doesn’t do this for us.

3 Likes

@looperlative Sorry for the intense output from my side. I had the three LP3s in my project but didn’t use them so far in parallell.

After now setting Loop, Trackselect, Undo (Trigger) and Redo to the Knobs 1 & 3 and switches B & C on all loopers (on pages 1-3) and recording some takes again some problems occured:

  1. The DSP spikes returned. Now even if the LP3s are not loaded and nothing is playing CPU/DSP meter is 'jumping - still investigating if I can do something against it). I bet it’s because of the multiple LP3s. These spikes are really annoying and I changed nothing but using the 3 LP3s. As said, I’m still investigating…

  2. I connected MIDI out from 1st LP3 to 2nd and 3rd (and set them to MIDI sync, 1st is set to selfsync) and when I record on 2nd and 3rd LP3 they stay not in SYNC. I thought MIDI Sync makes Record and endpoint synced to 1st one…

EDITs:
1st additional Test: I deleted one LP3. Spikes are still there. Mainly after hitting undo.

2nd test : Deleted 2 of 3 LP3s. Spikes are still there. Confusing.

3rd test: disabled input & output processing & send Clock in dwarf and set sync of dwarf to internal (not Ableton). Can’t reproduce Spikes for 2 minutes… further investigating

4th Test added again a 2nd LP3: DSP/CPU SPIKES! :frowning:

1 Like

A recorded loop will be continually reading memory in a sequential fashion. This should be fairly consistent over time.

Undo levels are stored to the Linux file system. When you press undo, it reads a previous version of the loop into memory. It does the file read in a lower priority work thread.

With 1 convolution reverb, 1 Gaffa and 1 LP3 all active, I see no spikes. I’m seeing 45%-47%. If this thing suddenly goes wild with a given combination. then it sounds like a system interaction. Perhaps somebody from MOD can weigh in here.

1 Like

Another thought here is that you may be running low on memory with all these time-based effects. Linux doesn’t behave well as it starts to run out of memory. What you may be seeing is Linux garbage collecting to free up memory. I’ve seen this in other embedded systems unrelated to this, but there is certainly a possibility that it is happening here.

1 Like

@looperlative Thank you! The RAM is at something like 62%. Shouldn’t be a problem!? I’m not expecting this to be solved in a short run. I worked with so many platforms and what I like here is the open ear and willingness to solve problems in direct contact. Don’t wonder if I’m away for some days and then come back to a topic… Some things just need time.

Did you only load one convolution verb, one Gaffa & one LP3? Are you at 128 samples latency? I could of course provide a project where the problem is obvious.

What about the syncing issue? Am I right that 3 LP3s should be able to sync to each other? Am I doing something wrong, connecting midi from LP3 (1) to LP3 (2) and LP3 (3) and setting 2 & 3 to midi sync? Am I missing something? They do not sync…

1 Like

Currently that won’t work because of decisions made in the platform. Let me have a chat with MOD and see what their recommendation is.

2 Likes