Can't select CV output for macro control

I’m trying to follow this tutorial for having macro controls with the device knobs on my Duo X:

But for some reason, I can’t select or see the CV port of my “control to cv” plugin for the control.

I also tried a LFO plugin without success. What kinda worked was loading the factory preset “CV gen 8th drone”. There I could see a CV port once after I opened the CV port name editor of the according plugin.

Am I missing something? I’m on I posted this here instead of bugs because I see a small chance that my modifications to make USB audio work broke something with CV, even though I limited my modification to the required minimum.

With my Mod Duo X I did this successfully as described in the wiki linked above. Here the macro controls work reliably and an ingenious extension, a modular “anything goes” device. It may be that on some knobs and faders this is not supported and therefore not displayed. Try the macro controls on different knobs and faders.
(The Mod Duo X is really fun and makes me want to make music again. Linux can be so simple. :-D)

Might be one parameter that cannot be mapped to CV, but if you have some options available the rest should be there too. (that is, either you get all options, or none)

Did you perhaps forget to click on “Manage CV Ports” on the top to enable the CV output of the “control to cv” plugin?



1 Like

For the sake of completeness: Yes, there was a fundamental misunderstanding on my side how CV actually works on the DuoX.