Can't load certain Beta plugins

On the Duo X I’ve tried to use certain Beta plugins, I figure this is because they are still beta but still thought it good to mention.

They just say Error adding effect. Probably a connection problem.
Or simply Error adding effect

  • Tracker MDA
  • Tal-Reverb-II

(there are others, but since I can’t easily search for Beta plugins I will append to this topic as I find them)


Thanks for reporting :slight_smile:
That’s indeed why these plugins are still in beta - they were not tested enough to go into the production plugins.
Just to help troubleshooting: this happens when you try to load the plugins and they don’t load at all, right? So you can even use them in your chain. Am I correct?

Exactly, this happens when I move the plugin from the constructor menu into the pedalboard.

@dreamer, I’ve pushed an update for the TAL-Reverb-II. Please have a look, the new build is version 0.0-7. Not sure yet what the issue is with the MDA Tracker.

Please do note, that that not all the plugins in the beta store are actively maintained, tested or supported. There are many plugins in the beta section that work just fine, but there are also quite a few that have issues, ranging from small bugs to non-functional plugins.

1 Like

@BramGiesen hmm, I did see the updates and was able to update both of the TAL-Reverb plugins. Both I’m able to load now. Good work! :slight_smile:

Maybe we should have an alpha section for such plugins first. And then beta when they are actively being tested and in the process of integrating with the stable list.


Hello @dreamer, @BramGiesen and @jon,

I installed TAL-Reverb II by hand and the plugin detail shows version 0.0-7 in the plugin store and in the constructor plugin list.

When I drag and drop it in the pedalboard constructor and click on the info button, it still shows version 0.0-5.

Grreetings and God bless, Marius

Shortly after I updated the plugins they also still said 0.0-5 in the info screen, but a moment later the UI had updated and they said 0.0-7

1 Like

@mj_prod have you checked if what @dreamer is describing also happened to you?

Hello @jon Jon,

I looked for Ta-Reverb-II in the pedalboard library and found this

After opening it via 192,168.51.1 in Opera it downloaded a new version of Tal-Reverb-II amongst other plugins.
Then I changed to another pedalboard and tried it again, this time with safari, it downloaded new plugin versions again.
Now it shows 0.0-7 everywhere.
I’m still on MacOS 10.14.4, by the way.

Greetings and God bless, Marius

1 Like

Ok. Thanks for reporting. We will be investigating the reason for these issues.