Can't install RakArrak plugins

I’m trying to install a couple of RakArrak plugins from the store. This seems to trigger the download of a whole rkr-bad.lv2 “bundle” of 37 plugins.

The problem is that the download seems to take forever and after more than 1h does not complete. On top of that, every other installation try seems “blocked” and does not start until I reboot the device.

Other plugins I installed lately seems to work.

1 Like

What is the device that you are trying to install them on? The MOD Dwarf?

1 Like

Mod Duo.

After more checking it seems that there are many other plugins that won’t download, expecially bundles.

For the moment I got:

The Red Zeppelin and Black Pearl drums

1 Like

It’s possible that some of these plugins (or newer versions) have no builds for the MOD Duo. Yet, I’m not sure. Some are not that new, so I see no reason for that.
@falkTX is it possible that this is the case?

Nope. I had some of those installed before the shutdown.

And in any case it’s not acceptable. If a plugin is not compaible with the Duo it should not show up in the available ones, or be marked in some ways as not compatible, or at least not leave the device in a state which requires a reboot.

all those are available on the duo. by the duo being the first platform there is no build without it unless manually defined that way.

this seems more like a temporary network failure.
or related to file size, where bigger ones fail (those containing a few plugins in a single bundle, or big plugins)

the downloads are sequential, so if one gets blocked for some reason (which yeah should not happen, need to investigate more) then any other you try afterwards wont work either.
in such a state, refresh the web gui and try installing the other plugins, skipping rakarrack that seems to have a problem for now

1 Like

Thanks for the correction @falkTX.
as I said I doubt that that is the reason @Tarrasque73 and actually…

You are totally right about this. If the build does not exist it won’t show up.
Sorry for my wrong info.
I will try to find a Duo where I can test what you are reporting so we understand if it’s something on your device/setup or in fact some bug with those plugins.

Could be related to file size. What I see is that the download bar never moves at all.

I tried closing the install indicator popup and installing another plugin, but nothing happened just like the old download was still stuck in the background. I did not try a “F5” web window refresh.

Please not thet’s not only RakArrak that has problems, but many others (I put a non exaustive list in the post). I’ll update if I find more.

Thank you for helping.

@Tarrasque73 and @falkTX,

I just tried to update the Rakarrack plugins on a Duo and everything went well.
Thinking that the issue was created when installing and not updating I tried to install Cardinal and it just installed with no issues - it took a while indeed, but it went ok.
So I’m not really sure what can be happening in your case, but it seems that it’s either with your Duo or your setup.
How can I help you further?

Well, I’ll try again installing the failed plugins as soon as I can, but the matter is then how can I help you help me? Can I provide logs or debug info in some ways? How can I get it from the device?

you can check the web browser console in its developer tools. typically such issues are reported there.

still think it is some network thing. or could be browser related too… lets keep discussion open.


Ok. Just for the record, I’ll give you the info I can before I can use the device again.

OS: Ubuntu studio
Browser used: chrome
Connection to device: cabled usb