Can't access modduo GUI on Mac

Hi guys! So I hadn’t used my Modduo in a while and wanted to make sure the firmware was updated before starting to monkey around with the new footswitch I received! The mod duo had no issue connecting to my mac (OSX version 10.12.6) in firmware update mode and I followed the steps to update it to v1.6.1.601. Now that the firmware is updated, I’m unable to access it via ssh, modduo.local, or at IP address The strange thing is when I open my network preference window I’m able to add a new connection called Duo Ethernet 2 which I assume is the Modduo, but it shows as not connected. The modduo still shows up without issue in firmware update mode, but I’ve still had no luck with the GUI. Any thoughts? Apologies if I’m missing something obvious, or overlooked an existing thread. Thanks in advance everyone!

1 Like

Hi @Evan, sorry to hear you’re having problems with your Duo.
Although not common, sometimes it happens that after an upgrade the storage gets to corrupted state.

Can you please try reinstalling the image following this steps:

  • Turn off your Duo
  • Leave the USB cable connected to your computer
  • As you hold left footswitch and left knob, turn it on
  • When you see the logo in the Duo screen, release the left buttons
  • A storage device will show up in the computer
  • Drop the latest image to the storage and eject it

The restore process will take a couple minutes.

In case it doesn’t work, try it a second time (just to make sure so we can rule this problem out).

Let us know how it goes after that.


1 Like

Hello Alex, thank you for your quick reply! I’ve already tried reinstalling the image at least 5 times now, and even tried reverting to an older image wondering whether there might be a compatibility issue. Any other ideas by any chance? Much appreciated!

1 Like

Yes, please try a different cable and a different computer.
We need to rule out those other two variables.

@ricardocrudo Anything else you suggest he can try?

1 Like

Can be a network configuration conflict, if you have other network interface in the same segment or other segment (i.e 192.168.50.x or 192.168.52) but with a netmask other than class C (ex:

1 Like

Yes, I’ve tried various cables, computers, and operating systems with no luck :frowning: As far as I know, I don’t think its a network config conflict either, I’ve also tried turning off my WIFI just in case.

Hi @Evan

When you boot your Duo, does it goes past the boot screen (MOD logo) ?

Can you navigate banks with the knob and load a Pedalboard?

Yes, the duo seems to function just fine otherwise! I see the logo and I’m able to navigate through the menus as expected, I just can’t connect to it.

FWIW I sometimes experience this same behaviour (on Mac, Safari and Chrome). If my MOD has been on for more than a few minutes without connecting via the browser, I can’t get the connection at all.

My workaround has been to keep rebooting the MOD and refresh the web page just after the MOD comes properly online. Normally this works within a couple of reboots for me.

1 Like

Thanks for letting me know, let the refreshing begin! I’ll update if this happens to work :slight_smile:

I’m having the same issue. When I ping the ModDuo, I get one response, then it times out…

1 Like

…and after three reboots now it works. Figures :slight_smile:

1 Like

Actually the first line is a notification that the process starts send ping-requests to the given address. So you get zero pong-responses.

@Evan please let me know if you got a connection, finally.
If not, could you please post the version strings from SETTINGS > Info > Version?
It should be the same as

version: v1.6.1
restore: b221042
system: 1a51cf6
controller: a5fa955
1 Like

I managed to investigate this problem on a Mac. On this machine (macOS version 10.10.5) it takes about 15 seconds until the network interface got a wrong IP address in the range 169.254.*.*. After a few seconds the interface seems to renew its leased IP address. A IP starting with 192.168.51.* works. I’m guessing this renewal might not take place, somehow.
@Evan You wrote the interface Duo Ethernet shows up in Systems Preferences > Networks. Could you please open the Advanced... window and try to force a Renew DHCP Lease?
Best regards

1 Like

@Jakob Thank you so much, renewing the DHCP lease fixed the problem! I really appreciate everyone’s help and suggestions!


I’m glad I could help.
For future readers: If you are renewing your IP again and again, you could also select Configure IPv4: Manually with a IP Address: 192.168.51.X where 1 < X < 254, e.g. Subnet Mask:
Best regards

1 Like