Cannot update Mod Footswitch (0.3.0)

I recently updated the Mod Duo via the update/upgrade prompt, then after that was successful it said to upgrade the foot controller with these instructions:

When I hold the footswitch down and connect with USB the device turns on but just has a bunch of black rectangles, and never says “update completed”. If I let go, the black rectangles remain, until I unplug USB and re-attach the CC cable.




Is your MOD Duo up to date?
Do you know it is a new unit with the new kernel, or the old kernel?

1 Like

Yes, I had just updated it, and don’t get prompts to update the Mod Duo, just the foot controller/footswitch.

The system information isn’t copyable to paste here so here is a screenshot.

exactly same problem here - please help :slight_smile:

you are updating through the webgui settings? do you connect the footswitch to the MOD unit via usb while holding down the 1st foot down (of the footswitch device)?

Hi, thank for the quick replay!

Yes - I did exactly as in the manual.
With USB cable and holding down 1st footswitch


Working now: So I just tried this again and had the same behavior with the blocks all across on the startup. Then, I accidentally just plugged it in to the mini-usb on the foot controller without holding the first footswitch down and it booted up and said 0.4.1 on the right panel.

So it looks like it is updated now.


Hahaa - thank You - it worked here too!