Cannot connect via Bluetooh for only Mac, but can using iphone or iPad

For some reason, I can’t connect to the Mod Duo X web interface when I connect via bluetooth, when on a mac.

From this forum post, Suggested bluetooth dongle - #9 by Fish

I got the TP-link UB400,, which seems to be working fine when I use my iPhone or iPad.

But for some reason, I can’t connect to the Mod Duo X. Using terminal, I tried pinging the IP address, I get timeout:

(base) sunwookim@Suns-MacBook-Pro ~ % ping 
PING ( 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4
Request timeout for icmp_seq 5

Maybe this is relevant, but my device is an M1 Max Macbook Pro 16’, maybe it has to do with the new ARM architecture?? I doubt it, since it’s working fine on my iOS devices, which are also ARM based.

Does anyone know what might be causing this issue?


1 Like

Sorry for the bump, but does anyone have an idea why?

I just snagged an M1 pro MacBook 14, let me see if I have issues with my MDX and Bluetooth today.

Like you, I have never had an issue with connecting my iPad, but I haven’t tried with Mac OS.

Waiting for internet technician to arrive to install my new service, and after that I’ll give it a test and report back.


I can confirm no connection to my Mac.

Bluetooth does indeed connect, but cannot access the gui. I am using the exact same stuff I have been using with my iPad without incident.

Not sure what is up.


I’m gonna be without internet for a time. New service provider has to run fiber optics to my house and there is some bureaucracy to cut through before I will have new service running.

Fiber is at least a third of the cost of what I was paying Comcast lmao


@semmo and @Elk_wrath I found this issue a while back (also not working on my MacBook, but all fine on my iPhone). First I obviously thought that the issue was on our (MOD) side. Then I did a small research and apparently this is on Apple side.
Back in November with the new OS (or some smaller update for it) they broke a thing on this Bluetooth pairings for network devices (like the MOD Devices, you can also have printers, etc. using this methods…sorry that I can’t remember exactly what they call it). They admitted the bug I guess back in December, but since then they didn’t fix it either answer when they will do.


Good to know, hopefully that will get addressed in the next MacOS release.

Still have my iPad that connects so I’m not too worried about it.

Thanks João!


Honestly I hope sooner…
My MacBook did an update yesterday or so and I was even thinking if it finally fixed it (shame on me that I didn’t read the change log). I still didn’t try it


Thanks for the explanation.

Just so that I know the problem better, do you mind sending a reference for what’s causing the problem? Maybe an apple issues forum page or something like that.


I can’t remember all that I found, but I remember that in one post I found an official Apple answer, anyway…MacOS 12.0.1 Monterey Bluetooth is… | Apple Developer Forums