Bluetooth issues with Chromebook or Windows

Based on the discussion on Release 1.1.0 mentioning Bluetooth, I got the SpeedLink VIAS bluetooth USB adapter.
But unfortunately it does not seem to work with my Chromebook (Pixel 2), Windows 10 (surface Pro 3), and I Mac I tried on also.
In all instances, I go in the Bluetooth menu, enable discovery, then look for the ‘Mod Duo 1-0170’ bluetooth device to pair with, it briefly shows that it’s connected, and then I see the status on the Mod Duo goes Disconnected…
I tried power off / on several time, but I do not seem to get any stable connection.

I was wondering if anyone had similar issues, or success on those platforms ?


Hi all,

same problems with my Nexus 7 (Android 6). But with my notebook (Kubuntu Linux) it works!

I have also the Speedlink Vias BT adapter and I tried the fresh ModDuo-1.1.1 firmware.

Regards, Holger

Thanks @Codeman for your input.
I tried with my Android 6.0 also, but it did not work.
I’m wondering if I should persist, try another bluetooth adapter, or stop trying with Windows or Mac as it will not work (I’m not so kin on installing Linux just for this :slight_smile: ).

FWIW It works on my android 5.1.1 phone.

@leDamien is your bluetooth adapter version 3.0 or 4.0?
We only have bluetooth 4.0 adapters here, so we haven’t tested it with 3.0 yet.

One thing that helps under Windows is enabling discovery while still connecting to it.
Because Windows take so much time to connect to bluetooth, sometimes the 2 minutes timeout is reached.

On the computer I have Windows 10 and access the MOD via USB by Chrome, MOD have the Bluetooth adapter 4.0 and can access only by Android. The windows can Bluetooth connection, but Chrome does not find the address (ip I think it’s a missing driver.

Did you connect to the bluetooth network?
It’s not just needed to pair and connect the device, you need to connect to its network.

See (step 7)

I could now, all right.

@falkTX , it was bluetooth 4.0.
I did not check the wiki for this, so I’m going to try again, but I need to find a new adapter, I let it plug while walking around the mode in my bag, and I broke it :sweat:
So I’ll give it another try soon, but it’s good news from @Yan :smiley:

Hi @ll,

I got Android 6 (on Nexus 7) and Android 5.1 (on Samsung S3 mini) running via Bluetooth: You have to disable WLAN for getting network running via BT! But it is very slow and not really usable on my devices.

Regards, Holger

In win10 layout appears differently tutorial form. At first I thought it would not be the same procedure, because there is no item of option 2 - “Join a Personal Area Network”, show only “Settings”. I was not doing the 7 item ‘Connect using’ then ‘Access point’, thinking that he would do it alone. My mistake.

hi, i use the bluetooth with windows 10 and it works fine. but everytime i power up the mod duo x i have to go in the settings menü and press the discovery button , than connect to network on windows. is that the workflow i have todo every time i start the mod duo?