Bluetooth dongle for Mod Duo X

Hi everybody.
I’m going crazy with my Mod Duo X and bluettoth connection.
I tried 2 bluettoth dongle and none for them work .
I can authentify the bluetooth connection betwin the Mod Duo X and my tablett (or my phone) but then I can’t connect to the device.
It was perfectly working with the Mod Duo (not Duo X) I sold 6 month ago.
So does someone here know what bluetooth dongle works with Mod Duo X and can confirm it works? I don’t want suppositions.

Did you try with v1.11 yet?

yes of course, I couldn’t wait. It doesn’t work either with V1.10.
I can pair my tablet and the Mod Duo X. But then there’s no option to select internet via this bluetooth connection. The bluetooth windows for Mod Duo X device is empty!
It’s the same problem on all android devices I tried.

That is unusual/unexpected since the overall OS is exactly the same across all units.
And in v1.11 all possible bluetooth usb drivers are enabled in each individual device kernel.

Can someone confirm to have bluetooth network working on v1.11 ?

Here’s sreenshots of the issue I have with android devices.
My tablet and Mod Duo X are paired, no problem here

Of course mobile data and wifi are off.
I open Mod duo X bluetooth option and this is what I have

No option to choose this bluetooth connection for internet connection.
I hope it’s more clear.

I understand that, just can’t explain the why yet. Because if this worked on the Duo it ought to work on Duo X too, the system bits are pretty much the same for all units.

Hi @falkTX
I there any news about bluetooth issue.
You were wondering if the hidden thing in android was removed.
So taday I tried to connect to my Mod Duo X with an old tablet that hasn’t be updated since many years. This tablet was perfectly working with the Bluetooth dongle and a Mod Duo.
But I wasn’t able to connect to the Mod Duo X.
The two device can pair but then, like on all other android devices I tested, there is no option to enable web connection via the bluetooth connection.
So something is wrong but it doesn’t came from android.