Arduino shield information/git incorrect


Currently I’m investigating creating my own footswitch pedal with the Arduino Shield. I looked for hardware documentation and found

However, I could not successfully clone the repo.

I know that the referenced is old and is probably – is this correct? Cloning this repo recursively failed, though.

Who can give me hints where the correct sub repos are or fix the repo?

At Arduino Shield – MOD Devices website there are different pictures of the shield. Probably is the current one, is this correct?

Thank you!

That looks like the correct repository, but the KiCad submodules are read-only now. I was able to get most of them to work by changing the submodules to https://, but it’s still not 100%. It looks like moddevices needs to update their GitHub repo for the Arduino shield.



@falkTX do you know who can give more information on that or can update the repo? @ricardocrudo does not seem to be with mod devices or at least the forum any more.

We will take care of it at some point, there is quite some work that needs to be done in regards to control chain.
We are timing that for the release of the CC expression pedal, so we get everything related done together.


@falkTX thank you!

hi @falkTX !

is the control chain library update still waiting until release of the expression pedal, or is it currently functional with a Duo X? …i’m talking about the arduino shield library…


That would be something for @Jan to reply, he knows more about the subject.
He is/was taking some holidays but will be back next week, so I guess to reply here soon.


so yes to both :sweat_smile:

As far as I’m aware, the Arduino shield library has always worked for the DuoX (all our devices run the same code that talks with the peripherals)

What doesn’t work right now, and is indeed still awaiting the expression pedal before an update, is using the control chain library with newer Arduino IDE versions (I found it stopped working at 1.8.10 and up but have yet to find the time to look into it a bit deeper)

I hope that helps


thanks, @Jan… great to know it’s just an IDE version issue!

1 Like