Any troubleshooting guide for custom control chain devices?

My custom control chain device on a breadboard has stopped being recognised by the MOD Dwarf for some reason (“No control chain devices connected”), although it was working when I have fisrt time put it together. I may have screwed it up at some point in time, so I wonder somebody can recommend a step-by-step troubleshooting guide?

UPDATE: Nevermind, I’ve found a troubleshooting guide here. Trying to follow it.

Also, I have about 4V voltage in my 3,2V circuit, and the reason seems to be the transciever, I’ve found it out by trial and error; without the transciever there is perfect 3.2V voltage in that circuit (I’m using MAX489EPD+ as a transciever). Although everything seems to be wired up exactly as on an Arduino shield schematics. I’m not an expert in electronics, so two-part question here, pardon my ignorance:

  1. could this higher voltage in the 3.2V circuit have somehow damaged MOD Dwarf’s host control chain?
  2. any ideas why the transciever increases the voltage?

I’m also not the best expert on electronics, but on this one (and not being sure if that is the case) I would say that is possible.

Anyway, @Jan may be able to offer you better help on this one.

1 Like

…though, looking at the datasheet for ISL83491 (presuming this same transciever - as on the Arduino shield - is used in the control chain on the MOD Dward’s side) I see that it is, quote, “Interoperable with 5V Logic”. The way I read it, there should not be a problem communicating with MOD Dwarf over 5V logic.
I would really appreciate an expert opinion on this (@Jan), thanks in advance!


ah you beat me to it, I was just about to reply :wink:

you are right, the Dwarf uses IC’s from the same family, so the higher voltage here should not cause any damage.

I’m not fully understanding your second question though, is the Dwarf increasing your measured voltage when connecting compared to connecting over USB? and if so which line are you measuring?
Perhaps as the Dwarf provides 12V, perhaps converting this down for the Arduino already results in a higher reference voltage? just a guess though!

PS, regarding debugging, you can also run cc-master with debug arguments on the Dwarf directly if you ssh into it and restart the service accordingly over the right serial interface (found in /etc/mod-hardware-descriptor.env)

So for the Dwarf it would be the following commands:

systemctl stop controlchaind
controlchaind /dev/ttyS0 -f

hope that helps!

Ah, let me clarify this one: as you may have noticed, I’m using Arduino Pro Micro (Leonardo), which has only 5V reference voltage, and does not have 3V, so I’m using L78L33ACZ-AP to recreate 3,2V circuit out of 5V reference. Now, when I include MAX489EPD+ transciever that I use instead of ISL83491 (or similar full-duplex 3V transciever, which I don’t have) into 3,2V circuit, I’m getting ~4V on the Vin pin, and overall the voltage in that ‘3,2V’ circuit is ~4V as if the transciever somehow uplifts the voltage. This is without connecting the breadboard to Dwarf, just with powering Arduino up with a 12V external on RAW pin, but, obviously, it’s the same when powering form 12V that Dwarf supplies.
I do realise now (and this is really embarassing) that since MAX489EPD+ is a 5V IC, I shouldn’t have used it in 3,2V circuit at all.
Now that I know that MOD Dwarf is ok with 5V logic, I can probably make the entire schematics running 5V without that extra 3,2V circuit.
What I can’t understand for the life of me is why my breadboard was working first time I put it together. It didn’t occur to me at that time to measure the voltage in the circuit, I was so excited it was working ))

Also, thanks for the debugging tip!


Ok I got the cc-master running in a debug mode, but nothing happens beyond this:
Screenshot 2022-04-12 005339

When I connect my breadboard with a Button.ino loaded, I still get nothing. I think I’ve broken something in the MOD itsellf, but I can’t get my head around what went wrong and how… (((
Any other ways I can check whether control chain circuit is working on the Dwarf?

Just a thought: could it be because of a firmware upgraded to, some conflict with the Arduino Control Chain library not being up to date?

First of all sorry about hijacking your topic but I couldn’t find a way of creating a new one, so I went for the closest one :slight_smile:

I am new to mod devices and I’ve recently got a MOD dwarf and a CC Shield in the hope to play with and arduino Uno

I have tried the example pot setup but it didn’t work with the dwarf, so went through the troubleshooting guide…I’m now at the cc-master step and the response I get is
steph@Tosh:~$ controlchaind /dev/ttyUSB0 -f
[cc-lib] control chain finished

Any ideas?

1 Like

I fixed that for you and now you should be able :slight_smile:

Yes. Something went broken with the library on some Arduino IDE release and we still didn’t manage to get it fixed (mapped for a bigger update on the Control Chain).
Try using an Arduino IDE version like the 1.6.13


Thanks for the quick reply, I’ve just tried 1.6.13 but that made no difference (previously using 1.8.16)


I think you may need to re-install the timer library as well (can’t remember if this is the exact name)

1 Like

I’ve now re installed Control chain and Timer One, no change in behaviour…

1 Like

@Jan any idea what may be wrong or @GreenfieldsDesign should try more?

1 Like

Hmm how are you connection your device?

I use arduino IDE 1.8.3 with an Arduino Uno and can use the pot example without issues.
One important thing is to install the TimerOne library from within the Arduino IDE.

For debugging on the Dwarf itself you can use these commands when connecting with the ControlChain conenctor. or if you are using USB, you can replace the last command with:

controlchaind /dev/ttyACM0 -f

or similar

hope that helps!