Android phone with USB cable on the Dwarf


Anyone had any luck accessing the web UI from an android (A12 in my case…) connected with the USB cable.
Is there a way the dwarf can be recognised as network USB?
I bought a usb-c adapter and was trying to understand if such connection is possible…



Are you somehow able to set on the Android settings that you will access the Internet over the MOD Dwarf? A bit similar to what you would do if you were using Bluetooth


It’s not working for me. Here is what I’ve done :

  • disable wifi and LTE
  • connect USB type B from the Dwarf to the USB C on my phone
  • go to and then to with Firefox 100
    :face_with_raised_eyebrow: connection failed !

It is possible to go further João ?

1 Like

I’m honest with you. I have 0 experience in trying such a connection.
Theoretically, it should be possible. But I’m not sure how much the Android system allows or blocks ethernet devices over USB.

What is the Android version on your device?


Android 10 (books tablet) & 11 (LG G6 with Lineage OS)

1 Like

I have a Samsung A12 with latest Android 11 patch.

when I plug the USB into my USB-c adapter the system does trigger the USB Notification and if I click on it I get back the following screen
However I can’t really change anything in order to try other modes

I even tried to switch plane mode and so on but I am stuck there not being able to select any other mode and neither access

I managed to force USB tethering from developer options when i connect the cable but still no access to the web UI
Unfortunately my phone here does not seem to have any OTG option i can select
@Rom perhaps can you make sure OTG is enabled on your devices and see if works with such setting?

1 Like

OTG seams to work here, but my devices are seeing the Dwarf as a midi controller, so they propose to open midi apps when I plug the Dwarf ! No WebUI here…

1 Like

Aren’t you using Net+MIDI on the USB B settings? If you put only network does it keep recognizing as a MIDI controller?

1 Like

Yep !

Nope, but still no webUI

1 Like

I would really need to sit and investigate it, but I’m afraid that I don’t have much time for that now.
I never tried to do this on Android either with other devices. Only Bluetooth connection.

I will try to do some more fiddling and i will keep you posted if i get somewhere


Cool! Thanks :slight_smile:

We have some initial promising setup done for 1.14, where a MOD unit connects to the network generated by an android phone via usb tethering.
The important part missing is displaying the access IP somewhere on the device screen.

We also had success in having the unit creating an open WiFi hotspot.

These should go as features in 1.14 release