Aida trainer module not find error —Any Help?—

HI everybody ! previously I used the trainer to model a Fender hot Rod Deville amp. Now im trying to model again the same amp but with another character, but, the trainer is sending me several errors

I attached a screen capture of the problem, can somebody had the same problem? could you help me please?


1 Like

I’m seeing this error now, too. Looks like something in the code changed at some point. Not sure who manages the code there, but maybe @itskais has some ideas?

My error message is slightly different:

Checking GPU availability... GPU available! 
Getting the code...
Checking for code updates...


ModuleNotFoundError                       Traceback (most recent call last)

<ipython-input-1-b52b4be1fb1a> in <cell line: 13>()
---> 42   from colab_functions import wav2tensor, extract_best_esr_model, prep_audio
     43   import plotly.graph_objects as go
     44   from CoreAudioML.networks import load_model

1 frames

/content/Automated-GuitarAmpModelling/ in <module>
     14 import CoreAudioML.miscfuncs as miscfuncs
     15 from CoreAudioML.dataset import audio_converter, audio_splitter
---> 16 import as training
     17 import CoreAudioML.dataset as CAMLdataset
     18 import CoreAudioML.networks as networks

/content/Automated-GuitarAmpModelling/CoreAudioML/ in <module>
      2 import torch.nn as nn
----> 4 from auraloss.perceptual import FIRFilter
      6 # ESR loss calculates the Error-to-signal between the output/target

ModuleNotFoundError: No module named 'auraloss'

Add as the first code line

!pip install auraloss


That fixed it! Thanks! How do we get it changed permanently on the backend?

1 Like

@madmaxwell can you please add it to the AIDA colab notebook? :pray:t4:

1 Like

But I see we’re installing auraloss on

in the 0. Set-up step. So maybe you’re not using the script above?

@madmaxwell you’re right.
@malfunction54 this script should work for you without issues normally, isn’t it the case?

1 Like

I’ll try that link and update here.

Update: It looks like I was using an older link. The link above works with no modifications

1 Like

It worked !!

i’ve insert the bit of code — !pip install auraloss — that was missing at the beginning and voilà :raised_hands:t2:


I can’t seem to find a link to the most current collab notebook on the forum. Can we create a topic with the current canonical link so everyone is using the correct tool?

1 Like

Hi :slight_smile:

if the link above works as you said —i haven’t tried yet— just post it as a new topic and we will follow :raised_hands:t2:

1 Like

It appears I got the link from the best practices guide blog post. In that post, the collab notebook URL is

vs. the one linked above at:

I assume the second link is the correct and most current one. If that’s the case, we need to have @LievenDV update the blog post in addition to maintaining a canonical reference to the correct collab notebook.


Genius !! :fire:

@malfunction54 correctooo, thanks for pointing that out c:
EDIT: I’m updating the best practices blog post now


Thanks! I can confirm that I see the updated link in the blog post.

1 Like