1.13.3 - Issue with load/manage snapshots [SOLVED (sorta) not a MOD issue]

I’ve a pedalboard with a few snapshots.
The load/manage snapshots dialog only lists one (which if I click on comes up with a select list showing all) but it does not seem to allow me to load or delete (Which I seem to remember it did before)

I’ll try to get a screenshot.

iPad browser over USB.


Hello @Smanth Samantha,
is the snapshot list currently assigned to a button or knob?
If you un-map it you should be able to delete an entry or rename it.
It could be a MOD Gui issue as well…
Hope that helps.

Greetings and God bless, Marius


So, some more details.

  1. Create a new pedalboard.
  2. Create 4 snapshots (using snapshot save as) A,B,C & D
  3. Snapshot D is active.
  4. Select load/manage snapshots, only one snapshot is visible; I seem to recall this used to be a list.
  5. Click on the snapshot and a list appears
  6. I select A
  7. All I can do is close the dialog, which I do … snapshot D remains active (Rather than the selected snapshot A)

hi @Smanth !

i’m not seeing what you’re describing. when i do exactly as you describe, i immediately see all 4 snapshots, along with “Default” in the load/manage dialogue. from there, i can select any snapshot (which also activates that snapshot), and i can delete any snapshot (including Default). i never see the smaller flyout window which is shown in your screenshot.

the behaviour i see is what i have always seen, and what i expect - like what you “seem to remember it did before”.

sorry… that’s not really any help for you! :frowning: it seems like there’s something strange going on with your MOD device or your GUI setup.

is this on a Dwarf?
does the same thing happen if you connect to a desktop or laptop computer for the GUI?
do you have any peripherals connected to the MOD device, other than the iPad?

and, just for completeness, my full version info:

Build Date: 2023 Sep 06 11:08:43
OS Version:


THANK YOU @plutek!

My first reaction was … d’oh, it’s because I’m using kiosker on my iPad, but when I tried safari and firefox I saw the same issue.

I fired up a linux laptop and it worked as it should :confounded:

There is a later version of IPadOS (v16.7.2) that I’m currently installing and if that does not work then I will try 17.1.1 … I shall report back here in case others run into similar.

I don’t want to say bl00dy Apple, I love my Macbook M1 … but it refuses to see the Dwarf over USB; my googling indicates this is due to some IO design flaw in the M1 system USB :frowning:

update: iPadOS v16.7.2 exhibits the same problem :frowning:
and so does iPadOS v17.1.1 … bah humbug!!


out of curiosity, what version of macOS are you on on your M1 macbook? I’m a little nervous to upgrade to the newest one…

1 Like

@oeSmash Well, I did have Ventura v13.6 … I’ve just updated to v13.6.1 and now I am able to access my Dwarf from my Macbook (MacBook Pro 13-inch, M1, 2020).

Tho given how many previous versions it has not worked on, I’ll not really believe it until it has worked for a few days with sleep mode etc etc … fingers crossed tho!


yay! :partying_face:
:crossed_fingers:that it continues!

…and does the snapshot list behave normally there?

1 Like

All the things I tried did not resolve it on my iPad @plutek
It works as ‘expected’ (as you described) on my Mac.