Sent support request, haven't heard back in over a week

I sent a very detailed email to over a week ago describing my problem, but I have not heard back. I realize it was just before New Years so I understand if there is a delay because of the holidays, but I’m wondering how long is normal before I should expect a reply.

In a nutshell, I attempted to update the firmware on my NAND Mod Duo following the steps here Troubleshooting Reinstall Duo - MOD Wiki . However, the Mod Duo never automatically reboots after installing the factory reset image.

I can try to help here.

Are you able to see the mass storage device and leds go blue?
From what you are saying, all steps work except the very final one, is that correct?

Yes that’s correct, everything seems to work (according to the instructions) until the last step, when the Mod Duo simply doesn’t reboot itself. I hold the FEL button and power up the Mod, connect USB, run and then I can see the blue lights and the Mod is recognized as an external device. After dragging the modduo-v1.9.3.1779.tar file to the Mod, ejecting it and removing the USB cable the red lights go on for a while, then the display appears to reset and the green lights go on. Then the green lights go off, and the display shows only the logo and “Mod Duo” text. And that’s it…

Sorry for late answer, we need to check this deeper, but lacking time at the moment.
For now, so at least you get a working unit again, see the steps on my other post on how to get the old kernel booting again

this specific issue with that unit type was fixed in 1.9.3 and the images/instructions we have in the wiki, so this must be something different.

1 Like

So following the instructions on the post you linked to:

  1. download
  2. download and extract the zip file
  3. “cd” to the directory where the zip got extracted to
  4. run sudo ./bootfix.osx -w /path/to/modduo-legacy-v1.9.1.1464-factory-image.raw

At this point it looks like the script stopped running. I see

URB 132
URB 135
libusb usb_bulk_send error -7 (= LIBUSB_ERROR_TIMEOUT)

in my stdout. Tried it again and got:

Speed = 480 Mbps
Expected 12Mbps, continuing anyway.
Start stage 1
usb_bulk_recv error -8 (= LIBUSB_ERROR_OVERFLOW)

I went ahead and unplugged the Duo (power and usb) and then re-powered to see if by chance the update worked anyway, but no dice.

I’ve had no problems with that USB cable before, but just to rule it out I tried it again with another, shorter USB cable and this time it looks like it worked. I saw

End of stage 2
All done 

Feeling optimistic, I unplugged power and usb, then plugged power back in and waited. However it’s been over 20 minutes and I don’t see any indications that the Duo is doing anything…no green lights, no red lights, no blue lights. The display shows only the logo. I tried plugging the USB back in and going to but the request times out. Tried pinging but that times out as well.

FWIW I’m using a USB 2.0 connection from the Duo directly into the USB port of my 2015 Macbook Pro. I am running Catalina so I had to follow the step here: How to run bootloader or factory restore on MacOS Catalina

I am afraid the unit is faulty. Would explain why the mainline deploy steps didnt work.

Please email about the situation, we need to replace the coreboard inside.

Was this resolved?

I am in the same situation with my NAND Mod Duo, followed all steps, but the unit never reboots, and on manual reboot nothing happens. I have been in touch with support, awaiting a solution that does not involve returning the duo, hopefully.
And if the coreboard must be replaced, can it be done by user :slight_smile:

1 Like