MOD - Audio to CV Pitch

I am on current firmware and had bugs coming from the CV connection assignments. Basically, it won’t assign. Anyone else have this bug?

1 Like

Welcome to the forum, @PedalEffected.

Please provide more information about your setup and what exactly you tried to do but didn’t work. You may attach images as needed.

From what I can tell, you seem to be trying to connect the CV out port to some other module/plugin, is that correct? Or are you trying to map it to some other control? In the latter case, did you enable that port?

2 Likes

The image I shot was misleading then. I was trying to show simply, the bug messages appearing when clicking CV to manage- no relationship or connection to audio of any sort.

I can send additional images if needed, in meantime below is the setup and use scenario when error popped up-

  1. Mod dwarf via usb to my mac, safari editor for mod working just fine. Downloaded new plug ins and updated to newest firmware. Rebooted the Dwarf and then went to create a new patch.

  2. I was using for the first time the new audio to cv pitch plug in. I clicked manage cv ports, selected both, the “bug message” popped up per original screenshot. They displayed the checkmark regardless and I then went to a plug in that receives CV. In its setup menu, under CV it says nothing available for CV. This is because it is saying that audio to cv pitch plug in has a bug itself.

  3. Other plug ins were working correctly with selecting manage cv and to assign the cv other places. I am specific referring to the plug in from my screenshot as giving me a bug when selected it’s CV to manage.

1 Like

It looks like your images didn’t come through. That can be because you’re a new user and there are automatic restrictions in place. @jon is the person to upgrade you.

However, from your description:

the only thing I recommend is that you add another Audio to CV pitch plugin and see if the same happens or create a new pedalboard and try that again. If this behaviour doesn’t change, it’d probably be a bug.

1 Like

Your suggestions are good- I’ve actually already tried things like a secondary plug in or rebooting aside from blank pedalboards.

Pretty sure it’s a bug, I posted to FB group and was directed here for further help potentially.

I’ve done cv assignments in past but it seems with this module there is a bug, I’ll look into it again tonight and try more things.

3 Likes

From your description, it sure looks like a bug.

If you have permissions to start a thread, please post it to the BUGS subsection.

Otherwise write to support@moddevices.com and the MOD folks will look into that.

2 Likes

The “manage CV ports” bug was already discussed above and fixed internally.

We will publish a public fix for this soon.

8 Likes

Hello,

Thank you for jumping in to let me know and offer the fix. I am using a Mod Dwarf but did not understand your reference to before “1.11.6 or 1.12-RC1” if you could clarify.

Please when possible, send over the fix and if any instructions for it.

Thank you again for your help here -

1 Like

Thanks @QuestionMarc. Sorry the delay @PedalEffected - I was out for a few days - I just upgraded your trust levels. You should now be able to post pictures and links

Simply put these are the full OS versions. The 1.11.6 is the one in production, so available to all users. The 1.12-RC1 is the release candidate for the next version that it’s still in tests and in “bug search”. If there’s no need for an RC2 it should get in production soon and become available to everyone.

2 Likes

Hey there, any idea when/where the update for the bug fix will be?

1 Like

It is already part of the 1.12 release candidate, eventually we will do a backport to 1.11 series

4 Likes

I apologize, I’m not certain what you mean -

I’m just looking ideally for a timeline to be able to use the module without a bug.

It sounds like 1.12 is soon to be released?

Or is an updated 1.11 to be expected released first?

Thank you, sincerely, for your help on this.

2 Likes

1.12 will release provided the community tests the beta version to identify bugs. Once the bugs are squashed in the RC versions, the production version releases.

The more people testing, the quicker it will be released.

I believe the development branch is splitting on this new 1.12 FW edition, largely due to the variance in hardware.

The original Duo will be using a stable fork of 1.11 if I recall correctly.

The Dwarf gets the cutting edge development, and the MDX follows the dwarf releases.

Edit: I’m not affiliated with MOD, so I am presenting my observations rather than an actual development workflow

4 Likes

…slight tweak: only production-run DuoX units follow the Dwarf. DuoX LE is pinned at 1.11 due to hardware limitations, i believe.

4 Likes

Quit making me sad, Peter.

4 Likes

Awesome intel - thank you!

I’m always open to beta testing if called upon lol

5 Likes

You are 100% free and clear to beta test.

You just need to manually flash the RC firmware for your device provided on the release page on the forum.

3 Likes

…yeah. saving my pennies. there was this tempting tidbit in @falkTX’s thread about 1.12.0-RC1:

Duo X rev. 3 units (with firefly rk3399 SoM)

ooooooh! :partying_face:

[…apologies for straying waaaaay OT…]

5 Likes

I’ve chosen to ignore that comment for reasons lol

3 Likes

Haha guys you can breath a sigh of relief, it’s just a different brand of the same SoM

4 Likes