Man... second DUO frozen... after installing latest OS

Hey Guys and Gals

I was just enjoying the latest OS (which I installed about two weeks ago through the GUI) and getting stuck in to building boards and having a lot of fun - was last using my DUO last night - I come back to it this morning, power on and then it’s stuck on the intro screen and is unresponsive… I tried the re-set options (holding down the left knob while booting up and even the FEL button on boot) and nothing is happening… I will go back to it again after work and see if it wants to play ball - otherwise I’ll have to return it to the UK distributor and get a replacement. This is the second time this has happened - and the second DUO I’ve had in the last year - I think it’s one of the older units so may request a newer one this time.

I’m not really expecting a miracle fix here as there doesn’t seem to be any obvious work-around (let me know if there is!!) - more to the point I love this pedal but have found the user experience incredibly frustrating - part of me regrets buying it but the other part of me loves open source and the huge possibilities it offers and love the flexibility too - it just seems in operation there are some flaws in this set up that - were I to be plugging in on an important gig and find that it had frozen or some other glitch / bug has developed from the rehearsal room to the stage - that I’m left high and dry with no FX…

I’ve been in touch with the place I bought it from and they say it’s within warranty - so I’ll probably return it and get a new one - but I really don’t want to have to keep doing this…

Sorry for the mini-rant - I could have bought an HX Stomp but I think the DUO is better in many ways - I just want it to work!!!

Thanks all

Hi @MikeFlynnBass,

We’re sorry you having this bad experience but hopefully this will have a miracle fix! :slight_smile:

I just saw your reply on Mod Duo X stuck on restore/update mode.

Please ping back here in this thread if you managed to restore your Duo or not so we can give you further assistance.


1 Like

Hi Leo

Sadly, I did try all the logical reset options - pressing both left knob and button while powering up - and the same with the FEL button and nothing changed - still stuck on the start up screens…

My one thought is that it’s due to this being one of the older DUO units - that isn’t liking the latest OS (it was 100% fine when I installed it - which is why I’m perplexed as to the reason for this freeze up). I’ve emailed MOD HQ and hope someone responds - I’m very happy to get a replacement but am concerned I get sent another older unit from the UK distributor and then end up in the same situation in a few months’ time…

Any thoughts on this are welcome - I’m hoping for a response before I return it via the retailer (who are being great about it all) - I’m just feeling sore after the hefty outlay and the year of frustration that’s followed


I’m sorry for your struggles. I can relate to how you’re feeling. My Duo once stopped booting right before I was leaving for my first significant gig. Having spent a couple weeks tuning up my pedalboards, EQs, presets, etc. I was pretty bummed; as a very inexperienced musician I didn’t have much of a backup plan.
I’ve used it a few times since then in public, but it’s never a good feeling wondering if your device will boot when you get to the gig. Just last weekend I had to replace the bootloader after a failed plugin install, which took most of my available creative time and momentum away.

One note about your troubleshooting - I don’t think holding the FEL button while booting is expected to resolve the state; rather it puts the device into a state where it is ready to communicate with the USB connection. From there you follow the instructions to replace the bootloader or OS image. For my recent fix, I booted up with FEL held in. The screen on the Duo didn’t change but I ran the executable as in the instructions and it dumped a bunch of text into the console and reported ‘done’. The Duo still didn’t change state but after the next reboot everything was back to normal.

I feel the same as you - I love the idea of the Duo and the open source roots. MOD the company seems like good people and I want them to do well. My thoughts go in different directions - lately I’ve been spending time again trying out pedalboards and building up a new Bank of boards that I like. The noise fixes have been crucial and have made a huge difference on some boards that were basically unusable before (I also added an isolated power supply, which probably helps). I really appreciate the recent efforts of the MOD team on the 1.8 release and it is good to see development moving forward again, but…

Like you I also want something I can trust to just work, without noise and random non-operational states. (I kind of like the HeadRush myself). I look wistfully at the full support for MIDI mapping + I/O, presets / patch transitions, and general polish (things like consistency between plugin levels, graceful handling of transitions between non-linear effects, more audio I/O options). While the Duo can and probably will have all these things some day, it might be a long wait. With a new device apparently being announced soon, the team will either be supporting 3 devices with one code base or with 3 versions of the code base; either way it’s a lot for a small team. One might conclude that the Duo will receive less explicit developer attention over time.

On the more exotic solutions end of the spectrum, I’ve also considered using PiSound running MODEP. One could also forego MODEP and achieve the same thing via a JACK client like Carla. Someone knowledgeable enough should be able to write a tool to convert or load Duo pedalboards. There would be a lot of initial hacking to recreate the important parts of the Duo experience, none of which fits into my ‘just works’ mantra. However, I can buy several PiSounds for the price of a Duo/X and be in total control of what is running (I could even play audio files! :p)

Good luck!

1 Like

Thanks man - I’ll try what you suggest but I suspect I’ll be filling in a returns form soon - will let goo know what happens - no reply from HQ yet on email though

Hi @MikeFlynnBass,

I’ve got a kickstarter edition myself and it is working fine with the latest version, might be something else.

I’ll check and make sure you get a response and proper support. The right channel for that is

Meanwhile, it doesn’t hurt to ask if you went through the optinos in . As @unbracketed pointed out, just holding the FEL button is not enough. Complete procedures are detailed in that page.

Thanks Leo

I’ve followed all the instructions to the letter and nothing is working - still frozen - I’ll get in touch with the support guys and see what they suggest